Opened 7 years ago

Closed 7 years ago

#7715 closed Bug (duplicate)

OPERA Bug Javascript errors when unlinking (it unlinks though)

Reported by: spgard Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: Cc:

Description

Using Opera 11.01 on Windows 7. In the demo site:

Place cursor in the empty document. Click Link icon and create link to anywhere. Save. Click on link text just created. Click Unlink icon.

The text gets unlinked but the javascript error window contains the following:

JavaScript - http://ckeditor.com/demo Event thread: click Uncaught exception: TypeError: Cannot convert 't' to object Error thrown at line 36, column 1541 in <anonymous function: setStart>(t, u) in http://ckeditor.com/apps/ckeditor/3.5.3/ckeditor.js?1303710662:

if(t.type==1&&f.$empty[t.getName()])

called from line 36, column 2468 in <anonymous function: setStartBefore>(t) in http://ckeditor.com/apps/ckeditor/3.5.3/ckeditor.js?1303710662:

this.setStart(t.getParent(),t.getIndex());

called from line 33, column 4284 in <anonymous function: moveToBookmark>(t) in http://ckeditor.com/apps/ckeditor/3.5.3/ckeditor.js?1303710662:

B.setStartBefore(z);

called from line 127, column 3200 in <anonymous function: selectBookmarks>(y) in http://ckeditor.com/apps/ckeditor/3.5.3/ckeditor.js?1303710662:

B.moveToBookmark(y[A]);

called from line 66, column 3006 in <anonymous function: exec>(m) in http://ckeditor.com/apps/ckeditor/3.5.3/ckeditor.js?1303710662:

n.selectBookmarks(o);

called from line 20, column 2220 in <anonymous function: exec>(k) in http://ckeditor.com/apps/ckeditor/3.5.3/ckeditor.js?1303710662:

return j.exec.call(this,i,k)!==false;

called via Function.prototype.call() from line 24, column 4345 in <anonymous function: execCommand>(l, m) in http://ckeditor.com/apps/ckeditor/3.5.3/ckeditor.js?1303710662:

o.returnValue=n.exec(o.commandData);

called from line 43, column 4134 in <anonymous function: click>(n) in http://ckeditor.com/apps/ckeditor/3.5.3/ckeditor.js?1303710662:

n.execCommand(m.command);

called from line 44, column 465 in <anonymous function: execute>() in http://ckeditor.com/apps/ckeditor/3.5.3/ckeditor.js?1303710662:

this.button.click(o);

called from line 10, column 349 in <anonymous function: addFunction>() in http://ckeditor.com/apps/ckeditor/3.5.3/ckeditor.js?1303710662:

return f.apply(g
this,arguments);

I only noticed this because I have Opera set to pop open the error window when a javascript error occurs. The error doesn't happen in Firefox.

Change History (2)

comment:1 Changed 7 years ago by Jakub Ś

Status: newconfirmed
Version: 3.5.33.0

You can also reproduce it in replace by code sample by unlinking the default link.

The detailed massage from dragonfly is:
Uncaught exception: TypeError: Cannot convert 'startNode' to object

Error thrown at line 1514, column 3 in <anonymous function: setStart>(startNode, startOffset) in http://localhost:8080/releases/ckeditor/3.5.3/ckeditor/_source/core/dom/range.js:

if( startNode.type == CKEDITOR.NODE_ELEMENT

called from line 1568, column 3 in <anonymous function: setStartBefore>(node) in http://localhost:8080/releases/ckeditor/3.5.3/ckeditor/_source/core/dom/range.js:

this.setStart( node.getParent(), node.getIndex() );

called from line 680, column 4 in <anonymous function: moveToBookmark>(bookmark) in http://localhost:8080/releases/ckeditor/3.5.3/ckeditor/_source/core/dom/range.js:

this.setStartBefore( startNode );

called from line 1402, column 4 in <anonymous function: selectBookmarks>(bookmarks) in http://localhost:8080/releases/ckeditor/3.5.3/ckeditor/_source/plugins/selection/plugin.js:

range.moveToBookmark( bookmarks[i] );

called from line 232, column 2 in <anonymous function: exec>(editor) in http://localhost:8080/releases/ckeditor/3.5.3/ckeditor/_source/plugins/link/plugin.js:

selection.selectBookmarks( bookmarks );

called from line 52, column 2 in <anonymous function: exec>(data) in http://localhost:8080/releases/ckeditor/3.5.3/ckeditor/_source/core/command.js:

return ( commandDefinition.exec.call( this, editor, data ) !== false );

called via Function.prototype.call() from line 581, column 5 in <anonymous function: execCommand>(commandName, data) in http://localhost:8080/releases/ckeditor/3.5.3/ckeditor/_source/core/editor.js:

eventData.returnValue = command.exec( eventData.commandData );

called from line 117, column 5 in <anonymous function: onClick>(item) in http://localhost:8080/releases/ckeditor/3.5.3/ckeditor/_source/plugins/menu/plugin.js:

this.editor.execCommand( item.command );

called from line 555, column 33 in <anonymous function: bind>() in http://localhost:8080/releases/ckeditor/3.5.3/ckeditor/_source/core/tools.js:

return func.apply( obj, arguments );

called via Function.prototype.apply() from line 304, column 8 in <anonymous function>(index) in http://localhost:8080/releases/ckeditor/3.5.3/ckeditor/_source/plugins/menu/plugin.js:

this._.onClick( item );

comment:2 Changed 7 years ago by Frederico Caldeira Knabben

Resolution: duplicate
Status: confirmedclosed

DUP of #6624.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy