Opened 6 years ago

Closed 6 years ago

#7733 closed Bug (fixed)

Flash video not displaying due to data attribute being added to object tag

Reported by: James Cunningham Owned by: Sa'ar Zac Elias
Priority: Normal Milestone: CKEditor 3.6.1
Component: General Version: 3.5.3
Keywords: IBM Cc: Damian, Teresa Monahan, Satya Minnekanti

Description

Steps to reproduce the defect:

Scenario 1

  1. Open the Ajax sample in IE.
  1. Paste the following flash video into source mode.
<object width="576" height="324"><param name="movie" value="http://d.yimg.com/nl/cbe/paas/player.swf"></param><param name="flashVars" value="vid=24944536&shareUrl=http%3A//animalvideos.yahoo.com/%3Fvid%3D24944536&startScreenCarouselUI=hide&"></param><param name="allowfullscreen" value="true"></param><param name="wmode" value="transparent"></param><embed width="576" height="324" allowFullScreen="true" src="http://d.yimg.com/nl/cbe/paas/player.swf" type="application/x-shockwave-flash" flashvars="vid=24944536&shareUrl=http%3A//animalvideos.yahoo.com/%3Fvid%3D24944536&startScreenCarouselUI=hide&"></embed></object>
  1. Switch back to WYSIWYG mode. (If you remove the editor here the video displays fine)
  1. Right click on the Flash placeholder & open the Flash Properties dialog from the context menu.
  1. Click OK on the Flash properties dialog.
  1. Remove the editor.

Expected: The flash video is displayed.

Actual: The flash video is not displayed (see screenshot).

Note: If you check the source you will see that CKEditor adds on a data attribute to the the object tag.

data="http://d.yimg.com/nl/cbe/paas/player.swf"

If you remove this data attribute & then remove the editor the flash video displays fine.

Scenario 2

  1. Open the Ajax sample in Firefox.
  1. Paste the following flash video into source mode.
<object><param name="movie" value="http://www.videojug.com/player?id=17b5b083-b45c-a7dd-6d7f-ff0008cb22b7"></param><embed src="http://www.videojug.com/player?id=17b5b083-b45c-a7dd-6d7f-ff0008cb22b7" type="application/x-shockwave-flash" ></embed></object>
  1. Repeat steps 3 to 6 in Scenario 1 above.

Expected: The flash video is displayed.

Actual: The flash video is not displayed.

Note: If you check the source you will see that CKEditor adds on a data attribute to the the object tag.

data="http://www.videojug.com/player?id=17b5b083-b45c-a7dd-6d7f-ff0008cb22b7"

If you remove this data attribute & then remove the editor the flash video displays fine.

Attachments (2)

IE_Missing_Flash_Video_Defect.JPG (29.7 KB) - added by James Cunningham 6 years ago.
7733.patch (646 bytes) - added by Sa'ar Zac Elias 6 years ago.

Download all attachments as: .zip

Change History (10)

Changed 6 years ago by James Cunningham

comment:1 Changed 6 years ago by James Cunningham

Summary: IE: Flash video not displaying due to data attribute being added to object tagFlash video not displaying due to data attribute being added to object tag

comment:2 Changed 6 years ago by Jakub Ś

Status: newconfirmed

This is true for IE6, IE8 and FF

Hasn't worked in CKEditor from version 3.5.3 revision [6455]

In IE6 in CKEditor versions 3.5.1 and 3.5.2 and 3.5.3 till revision [6454] flash content was not displayed on the page at all (not even an empty frame was shown)

comment:3 Changed 6 years ago by James Cunningham

I can also reproduce this in IE7

comment:4 Changed 6 years ago by Sa'ar Zac Elias

This's a dup of #7301, in which we've concluded that this is a IE bug in the sample level that does not require any change in the software level. With [6601] we've made the content at least editable again after hitting "Create Editor" on the 2nd (or more) time. I don't think there's anything we should, or can, do about that issue without over-complicating the sample.

Last edited 6 years ago by Sa'ar Zac Elias (previous) (diff)

comment:5 Changed 6 years ago by James Cunningham

If this is an IE bug how come Scenarion 2 described in the test case can be reproduced in FF 3.6? This defect can be reproduced in other samples as well as the AJAX sample (ReplaceByClass, Api, etc.) by following steps 1 to 5 mentioned in the test case and then for step 6 click on the preview button in the toolbar instead of removing the editor. As mentioned in the test case the problem arises when CKEditor adds the data attribute to the <object> tag.

data="http://www.videojug.com/player?id=17b5b083-b45c-a7dd-6d7f-ff0008cb22b7"

Why is this code being added?

comment:6 Changed 6 years ago by Sa'ar Zac Elias

Owner: set to Sa'ar Zac Elias
Status: confirmedreview

This attribute was added to properly support object-only structure (to be cross-browser, in fact). This attribute is pretty common actually. But at least we can prevent having it when not needed, to minimize the impact.

Changed 6 years ago by Sa'ar Zac Elias

Attachment: 7733.patch added

comment:7 Changed 6 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.6.1
Status: reviewreview_passed

comment:8 Changed 6 years ago by Sa'ar Zac Elias

Resolution: fixed
Status: review_passedclosed

Fixed with [6929].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy