Opened 9 years ago

Closed 9 years ago

#7736 closed Bug (duplicate)

Horizontal list changed to vertical when click in it

Reported by: datalink Owned by:
Priority: Normal Milestone:
Component: General Version: 3.5.1
Keywords: Cc:

Description

I have a horizontal menu made by an unordered list. If I open this menu all LIs are horizontal. If I click on a list element this element is changed to vertical.

Change History (6)

comment:1 Changed 9 years ago by Jakub Ś

Status: newpending

Could you provide us with an example file/files (html, css, js etc.) which you are using to get this result?

comment:2 Changed 9 years ago by datalink

Copy this to demo and click on a link.

  <div style="text-align: center">
    <ul style="margin: 10px 0px; padding: 5px 0px; background-color: #B58D45; list-style: none;">
      <li style="margin: 0px 20px; padding: 0px; display: inline;"><a href="index.php?page=home">Homepage</a></li>
      <li style="margin: 0px 20px; padding: 0px; display: inline;"><a href="index.php?page=test1">Testpage 1</a></li>
      <li style="margin: 0px 20px; padding: 0px; display: inline;"><a href="index.php?page=test2">Testpage 2</a></li>
      <li style="margin: 0px 20px; padding: 0px; display: inline;"><a href="index.php?page=test3">Testpage 3</a></li>
      <li style="margin: 0px 20px; padding: 0px; display: inline;"><a href="index.php?page=test4">Testpage 4</a></li>
    </ul>
  </div>

comment:3 Changed 9 years ago by Jakub Ś

Status: pendingconfirmed
Version: 3.5.33.5.1

Confirmed - for FireFox browsers from CKEditor version 3.5.1

comment:4 Changed 9 years ago by Jakub Ś

One more thing: the source code stays untouched. The view page option shows the correct output. Also switching between source and wysiwyg modes bring back the correct list view.

Only the wysiwyg mode acts weird.

comment:5 Changed 9 years ago by Frederico Caldeira Knabben

Status: confirmedpending

@j.swiderski, this looks like a DUP of #7221, which should have been fixed on trunk. Can you confirm it?

comment:6 Changed 9 years ago by Jakub Ś

Resolution: duplicate
Status: pendingclosed

My mistake - it works in trunk version.

DUP of #7221

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy