Opened 9 years ago

Closed 9 years ago

#7750 closed Bug (fixed)

[[safari/chrome]] not possible to create a new paragraph after applying paragraph format/ alignment/ language direction/ indentation with out focus in editor body

Reported by: Satya Minnekanti Owned by:
Priority: Normal Milestone: CKEditor 3.6
Component: UI : Enter Key Version: 3.6
Keywords: IBM Cc: Damian, James Cunningham, Teresa Monahan

Description

To reproduce the defect:

  1. Open Ajax sample.
  1. with out keeping focus in editor body click on any one of Alignment options( for ex: Align Center).

ISSUE 1: cursor not in editor body and when we type the text Center Alignment not applied to typed text & also Align Center icon not highlighted in the tool bar.

  1. Type some text and press Enter.

Expected Result: New empty paragraph is created.

Actual Result: No new empty paragraph is created and cursor still stays in same paragraph, no matter how many times we pressed enter.

Same issue happens when we apply language direction or indentation or paragraph format with out focus in editor body.

Change History (5)

comment:1 Changed 9 years ago by Jakub Ś

Status: newconfirmed
Version: 3.5.33.0

Till 3.3.1 pressing Alignment twice caused that style was applied. From version 3.3.2 you can't set Alignment without having focus in editor body.

After you type some text and press enter - no new paragraph is created. This is true from version 3.0 for Webkit browser. But if you press enter twice or more the paragraphs are created: (“number of times enter key was pressed” – 1).

comment:2 in reply to:  1 Changed 9 years ago by Satya Minnekanti

Version: 3.03.6 (SVN - 3.6.x)

Replying to j.swiderski:

Till 3.3.1 pressing Alignment twice caused that style was applied. From version 3.3.2 you can't set Alignment without having focus in editor body.

After you type some text and press enter - no new paragraph is created. This is true from version 3.0 for Webkit browser. But if you press enter twice or more the paragraphs are created: (“number of times enter key was pressed” – 1).

I could not create empty paragarphs on 3.6 branch and this is a serious issue.

comment:3 Changed 9 years ago by Jakub Ś

This is true. I could not reproduce it on version 3.5.3 and latest trunk version but it is reproducible in branch 3.6

comment:4 Changed 9 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.6

comment:5 Changed 9 years ago by Garry Yao

Component: GeneralUI : Enter Key
Resolution: fixed
Status: confirmedclosed

Enter key issue fixed with [6819] on branch.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy