Opened 10 years ago

Closed 10 years ago

#7818 closed Bug (fixed)

IE: Element Path bar & Tool bar icons not updating properly while inserting & Editing Tables

Reported by: Satya Minnekanti Owned by:
Priority: Normal Milestone: CKEditor 3.5.4
Component: General Version: 3.5.4
Keywords: IBM Cc: Damian, James Cunningham, Teresa Monahan

Description

To reproduce the defect:

  1. Open Ajax sample, with out focus in Editor body click on Table icon.

Expected Result: Table Properties dialog comes up and elements path bar remain empty.

Actual Result: Table Properties dialog comes up but elements path bar show body & h1 tags. (see attached screen shot Error 1.jpg).

  1. Click OK button.

Expected Result: Table inserted, cursor in last table cell & elements path bar should show body,table,tbody,tr,td tags.

Actual Result: Table inserted but elements path bar still shows body & h1 tags. (see attached screen shot Error 2.jpg).

  1. Click in a different Table cell, click on Align Center & Text direction from right to left icons in the Tool bar.

Expected Result: Cursor goes back to the cell,Align Center & Text direction from right to left icons highlighted in the Tool bar.

Actual Result: Cursor goes back to the cell,Align Center & Text direction from right to left icons are not highlighted still Align Left & Text direction from left to right icons are highlighted in the Tool bar. (see attached screen shot Error 3.jpg).

Tested in IE6 & IE7

Attachments (3)

error1.jpg (37.7 KB) - added by Satya Minnekanti 10 years ago.
error2.jpg (8.9 KB) - added by Satya Minnekanti 10 years ago.
error3.jpg (37.6 KB) - added by Satya Minnekanti 10 years ago.

Download all attachments as: .zip

Change History (12)

Changed 10 years ago by Satya Minnekanti

Attachment: error1.jpg added

Changed 10 years ago by Satya Minnekanti

Attachment: error2.jpg added

Changed 10 years ago by Satya Minnekanti

Attachment: error3.jpg added

comment:1 Changed 10 years ago by Jakub Ś

Status: newconfirmed

Issue1 : I did not get body and h1. I got body p or nothing in path bar. This is still incorrect.

Issue2: Path bar showed still body p or nothing. Same behavoir.

Issue3: Confirmed.

comment:2 Changed 10 years ago by Jakub Ś

From rev [6698]

comment:3 Changed 10 years ago by Wiktor Walc

Milestone: CKEditor 3.6

comment:4 Changed 10 years ago by Garry Yao

Resolution: fixed
Status: confirmedclosed

Fixed with [6879].

comment:5 Changed 10 years ago by Wiktor Walc

Version: 3.6 (SVN - 3.6.x)3.5.4 (SVN - trunk)

comment:6 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.6CKEditor 3.5.4
Resolution: fixed
Status: closedreopened

Based on wwalc comment, this should go on trunk. Am I wrong?

comment:7 Changed 10 years ago by Wiktor Walc

Yes, I've set the wrong milestone based on invalid version number, unfortunately. This bug appeared in trunk, so should be fixed in trunk first and then merged to 3.6.x.

comment:8 Changed 10 years ago by Wiktor Walc

I've reverted changes with [6800]. Another reason to revert it was #7821 (it looks like it may be related), so I thought that before committing it to trunk again it might be worth to recheck it.

comment:9 Changed 10 years ago by Garry Yao

Resolution: fixed
Status: reopenedclosed

I can confirm #7821 is instead a separate issue, which is also caused by [6698], but should be addressed separately.

Note: See TracTickets for help on using tickets.
© 2003 – 2020 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy