Opened 8 years ago

Closed 7 years ago

#7821 closed Bug (fixed)

IE: unable to type above the table

Reported by: Wiktor Walc Owned by:
Priority: Normal Milestone: CKEditor 4.0
Component: General Version: 3.5.4
Keywords: Cc: satya_minnekanti@…

Description

To reproduce the defect:

  1. Open Ajax sample, with out focus in Editor body click on Table icon.
  1. Click OK button on Table Properties dialog to insert the table.
  1. Table is inserted & cursor in last table cell.
  1. Using mouse or keyboard try to keep the cursor above the Table.

Issue:

In CKEditor 3.5.3 a paragraph was created automatically after clicking above the table. Currently nothing happens and there is no easy way to add content above the table.

Tested against IE6

Regression since [6698].

Change History (9)

comment:1 Changed 8 years ago by Wiktor Walc

Status: newconfirmed

comment:2 Changed 8 years ago by Garry Yao

It was introduced by purpose when I was working on #6629, it doesn't looks like a good manner for breaking ticket relevance, but the reason is that, this feature (automatically add empty paragraph before table if selection is inside body), even considered useful at times, is quite counter-intuitive and obtrusive, and been unable to revert makes it even worse, so we have tickets like #5378, #6217 and #7289, we have also complaints at forum.

I guess we'd leave it as is, leave a changelog in release to explain users, and look for a better way of introducing it in the future.

comment:3 Changed 8 years ago by Garry Yao

As discussed before, there could be various ways (e.g. keystroke override, helper tool) of bringing the fix (establish the paragraph) while they must all obey the rule that it should only happen upon user's intention, which means we must not make any change until it's sure that user really want to edit before the table.

comment:4 Changed 8 years ago by Satya Minnekanti

Cc: satya_minnekanti@… added

comment:5 Changed 8 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.5.4

comment:6 Changed 7 years ago by Jakub Ś

I believe this one will be fixed with #6847.

comment:7 Changed 7 years ago by Jakub Ś

Keywords: IE removed

#3986 was marked as duplicate.

comment:8 Changed 7 years ago by Jakub Ś

I believe this will be resolved by Magic Line plugin in CKE v4

comment:9 Changed 7 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 4.0
Resolution: fixed
Status: confirmedclosed

Yes, the magicline plugin came to solve problems like this.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy