Opened 10 years ago

Closed 7 years ago

#3986 closed Bug (duplicate)

can't place cursor before a table

Reported by: rejetto Owned by:
Priority: Normal Milestone:
Component: Core : Styles Version: 3.0
Keywords: Discussion IBM Cc: satya_minnekanti@…

Description

  1. empty the document
  2. insert a table
  3. try to place the cursor before the table (to enter some content)

you can't

This problem applies even to CKeditor 3, where you are adding a dummy <p> before the table apparently to workaround the problem. If this <p> is removed, the user gets in the same problem.

Change History (9)

comment:1 Changed 10 years ago by Garry Yao

Component: GeneralCore : Styles
Keywords: Discussion added
Milestone: CKEditor 3.x

You're right, but the affected browser for both v2 and v3 is Firefox, because of the browser itself of course, we're intended to figure out a way to allow this happen in future release of CKEditor.
We'll also open thread in ODE forum to hear from any reasonable suggestion for this feature later, please stay tunned.

comment:2 Changed 10 years ago by rejetto

Indeed, i confirm it to be working with IE, and tinyMCE having the same problem. I searched the firefox bug tracker, and was not able to find a report for this. Would it be a good idea me to open a ticket there?

comment:3 in reply to:  2 Changed 10 years ago by Garry Yao

Replying to rejetto:

Would it be a good idea me to open a ticket there?

That would be great, thank you.

comment:4 Changed 9 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.x

Milestone CKEditor 3.x deleted

comment:5 Changed 8 years ago by Jakub Ś

Status: newconfirmed
Version: FCKeditor 2.6.43.0

Since this is a discussion than in my opinion we have a general problem with exiting block-level elements.

Let's start with table:

  1. To get out of table at the bottom, you have to press down arrow.
  2. To get out of table at the top you have to press top or left arrow twice - "double-arrow" and start typing. That way new paragraph will be created above the table. As @garry.yao has said - this works in all browsers except FF.
  3. The newly created paragraph can be deleted but there are some browser inconsistencies. In Webkit and IE you have to use SHIFT+right-arrow(or End) to select whole text and than press delete. In Opera you have to select text, press DELETE, press down-arrow and then up-arrow.
  4. Additionally there is let's say edge case when you want to delete paragraph after table which ends the document. There are also some browser inconsistencies. You can read more about this issue here #7001

Div:
When you create a div it is impossible to get out of it using enter or arrows, neither at the top nor at the bottom. @garry.yao has pointed out these problem here: #6847
Blockquote
This case is almost the same as div, except that thanks to it's "toggle button logic" it is possible to leave it at the bottom. But again it is impossible to leave it at the top or at the bottom using arrows

Lists:
To leave the list at the bottom all you have to do is press ENTER two times and you're out. Again there is no possibility to escape lists at the top. I have tried to workaround the problem by creating first empty list element and then deleting it with backspace but there are some browser inconsistencies. You can read about it here: #8259

Forms
It is impossible to get out of form at the top, neither using arrows nor mouse. Getting out at the bottom is as easy as in tables.

I don’t know if this is possible but it would be nice to unify this behavior. Let’s say to get out of block you have to press up/down arrow twice quickly “double-arrow”. Since almost none of block-level elements, that start the document, allows for leaving them at the top and tables partially support it, sounds like a good idea (at least to me).
Leaving the element at the bottom is more complex – Adding new behavior to divs is no problem. Blockquote and List have their way to let cursor out (double enter and toggle button in toolbar). Perhaps this could be an additional way to leave those two elements.
Froms and Tables unfortunately can be exited with one-arrow press. To unify would meant to drop current behavior and implement new one. No other solution comes to my mind here.

One problem comes to my mind that could quickly emerge here. It should be also possible to easily delete those newly created paragraphs with a delete or backspace key.

There is one more edge case. What if you have to block-level elements next to each other like two tables or two divs and you want to insert something between them? Currently there is no such functionality. @datalink has pointed out this problem in #8032. In that ticked I have proposed sketch of a plugin that could insert paragraph or other element, dependant on enterMode, on demand (when pressing the button). Maybe it leads in the right direction.

This is just a draf of my point of view on the problem, I may have missed something, so don’t kill me at the start :).

Last edited 8 years ago by Jakub Ś (previous) (diff)

comment:6 Changed 8 years ago by Jakub Ś

This one is supposed to be fixed by #6847.

comment:7 Changed 8 years ago by Jakub Ś

This issue was duplicated in #8503

comment:8 Changed 8 years ago by Satya Minnekanti

Cc: satya_minnekanti@… added
Keywords: IBM added

comment:9 Changed 7 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed

DUP of #7821

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy