Opened 8 years ago

Closed 8 years ago

#7820 closed Bug (fixed)

IE: we can't come out of Table using mouse or keyboard

Reported by: Satya Minnekanti Owned by:
Priority: Normal Milestone: CKEditor 3.5.4
Component: General Version: 3.5.4
Keywords: IBM Cc: Damian, James Cunningham, Teresa Monahan

Description

To reproduce the defect:

  1. Open Ajax sample, with out focus in Editor body click on Table icon.
  1. Click OK button on Table Properties dialog to insert the table.
  1. Table is inserted & cursor in last table cell.
  1. Use mouse or keyboard try to keep the cursor after the Table.

Issue:

when we click out of the Table using mouse cursor going to first Table cell.

when we use arrow keys to navigate out of the table focus going back to last Table cell.

Tested against IE6 & IE7

Change History (8)

comment:1 Changed 8 years ago by Jakub Ś

Status: newconfirmed

True for IE6 and IE7.

If you press quickly down arrow two times you will get out of table.

comment:2 Changed 8 years ago by Jakub Ś

Occurs from rev [6698]

comment:3 Changed 8 years ago by Wiktor Walc

Milestone: CKEditor 3.6

comment:4 Changed 8 years ago by Garry Yao

Resolution: fixed
Status: confirmedclosed

Affects only IE6/7, fixed with [6879].

comment:5 Changed 8 years ago by Wiktor Walc

Version: 3.6 (SVN - 3.6.x)3.5.4 (SVN - trunk)

comment:6 Changed 8 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.6CKEditor 3.5.4
Resolution: fixed
Status: closedreopened

It looks like this should go on trunk, am I wrong?

comment:7 Changed 8 years ago by Wiktor Walc

My mistake. Garry committed it to the right branch based on the milestone and version number, but in fact this bug appeared in trunk so it should go there.

Reverted with [6880], also due to another related(?) issue #7821.

comment:8 Changed 8 years ago by Garry Yao

Resolution: fixed
Status: reopenedclosed

Fixed on trunk with [6882].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy