Ticket #7826 (closed Bug: duplicate)

Opened 3 years ago

Last modified 6 weeks ago

Source protection dosen't work for textarea tag

Reported by: maza Owned by:
Priority: Normal Milestone:
Component: Core : Output Data Version: 3.5.2
Keywords: Cc: spotlighter@…

Description (last modified by j.swiderski) (diff)

Set in config.js config.protectedSource.push( /<\?[\s\S]*?\?>/g ); // PHP code

If You use this code:

<textarea name="f[desc2]" cols="45" rows="10"><?php echo $oFormat->htmlToEnt($_POST['f']['desc2'], false); ?></textarea>

{cke_protected_x} dosen't apper in HTML mode. Source view shows:

<textarea cols="45" name="f[desc2]" rows="10">&lt;!--{cke_protected}%3C%3Fphp%20echo%20%24oFormat-%3EhtmlToEnt(%24_POST%5B'f'%5D%5B'desc2'%5D%2C%20false)%3B%20%3F%3E--&gt;</textarea>

Change History

comment:1 Changed 3 years ago by maza

  • Cc spotlighter@… added

comment:2 Changed 3 years ago by j.swiderski

  • Status changed from new to confirmed
  • Keywords source protection textarea removed
  • Version changed from 3.5.3 to 3.5.2

Works fine in HTML attributes, tags like form, p or span but it doesn't work inside textarea.

I have set 3.5.2 version because according to #4475 this is where attributes were fixed.

comment:3 Changed 20 months ago by j.swiderski

  • Description modified (diff)

comment:4 Changed 20 months ago by j.swiderski

Patch from #9205 fixes this problem.

comment:5 Changed 8 months ago by maza

After installing this patch this problem still exists :(

comment:6 Changed 6 weeks ago by Reinmar

  • Status changed from confirmed to closed
  • Resolution set to duplicate

Patch for #9205 indeed didn't fix this problem, because it's a different kind of issue - it has the same nature as #11223. I'm closing it as DUP - it will be fixed in #11223. Although, the fix will be about stop protecting source inside <textarea>, because there's no other solution - <textarea> cannot contain comments inside it.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy