Opened 8 years ago

Closed 8 years ago

#7858 closed Bug (wontfix)

IE 6 & 7: @ symbol is displayed in the editor when 0 is entered in the start text field in Numbered List dialog

Reported by: James Cunningham Owned by:
Priority: Normal Milestone:
Component: Core : Lists Version: 3.0
Keywords: IBM IE Cc: Damian, Satya Minnekanti, Teresa Monahan

Description

Steps to reproduce the defect:

  1. Open the Ajax sample in IE7.
  2. Create a numbered list containing 3 items.
  3. Right click on the list and select Numbered List Properties from the context menu.
  4. Change the type to Upper Alpha.
  5. Enter 0 into the Start field.
  6. Click OK.

Expected Result: The list should have 0, A and B as the numbers. (behaviour in FF)

Actual Result: The list has @, A and B as the numbers (see screenshot). In my opinion the list should not start with an @ symbol.

Note: This ticket is similar to 6470 which has been fixed.

Attachments (1)

numbered list dialog bug.jpg (28.2 KB) - added by James Cunningham 8 years ago.

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by James Cunningham

comment:1 Changed 8 years ago by Satya Minnekanti

Summary: IE7: @ symbol is displayed in the editor when 0 is entered in the start text field in Numbered List dialogIE 6 & 7: @ symbol is displayed in the editor when 0 is entered in the start text field in Numbered List dialog

comment:2 Changed 8 years ago by Jakub Ś

Keywords: IE added; IE7 removed
Status: newconfirmed
Version: 3.6.1 (SVN - trunk)3.2.2

True for IE6 and IE 7 from CKEditor 3.2.2

comment:3 Changed 8 years ago by Sa'ar Zac Elias

Resolution: wontfix
Status: confirmedclosed
Version: 3.2.23.0

This's how IE handles alpha-lists starting with values lower than one. We can not change this behavior, nor should, as the output IS correct:

<ol start="0" style="list-style-type: upper-alpha">

Note that though the list-style dialog was introduced with the 3.2.2, it had been that way since 3.0, using that code in source.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy