Opened 8 years ago

Closed 6 years ago

#7859 closed New Feature (fixed)

Editor area without iFrames

Reported by: Jari Pennanen Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: v4 Cc:

Description

Hi!

Is it possible to make multiple div's editable with contentEditable and sharedspaces so that there is no iframe? Similarly as commercial Weebly does.

Consider following:

<img src="http://a.cksource.com/c/1/inc/gfx/logo.png" align="right" />
<div contenteditable="true">lorem ipsum dolor...</div>

(Notice the align=right on the image tag.)

Thats why Weebly rocks. It can make the div's editable and create own UI blocks such as IMG with own editable UI.

This has been asked before, but admin did not understand what it was about. See #2657

Change History (5)

comment:1 Changed 8 years ago by Jari Pennanen

As a matter of fact, there exists interesting alternative, Aloha Editor. Try Aloha here.

comment:2 Changed 8 years ago by Jakub Ś

Status: newconfirmed

Currently for CKEditor v3.x it is impossible to make inline editing as presented here - http://mozile.mozdev.org.

CKEditor is able to wrap clicked div on the fly but all the contents will be placed in the iframe this is how it works by design.

Perhaps it will be implemented in one of future releases.

comment:3 Changed 8 years ago by Garry Yao

As planned by our road map, the "inline editing" creation of editor will be available at the incoming new version 4, please stay tuned and give your review to it later.

comment:4 Changed 7 years ago by Jakub Ś

Keywords: v4 added

comment:5 Changed 6 years ago by Garry Yao

Resolution: fixed
Status: confirmedclosed

This feature is now available in CKEditor from 4.0.

nightly.ckeditor.com/latest/ckeditor/samples/inlineall.html

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy