Opened 8 years ago

Closed 8 years ago

#7909 closed Bug (invalid)

Permission Denied to get property Window.document

Reported by: Freddie Bingham Owned by:
Priority: Normal Milestone:
Component: General Version: 3.5.3
Keywords: Cc:

Description

Occasionally, upon page load, I will receive:

Permission denied for <http://www.example.com> to get property Window.document

This is being thrown from wysiwygarea/plugin.js:

var doc = iframe.getFrameDocument();

which is calling getFrameDocument() in element.js, which dies on

return $ && new CKEDITOR.dom.document( $.contentWindow.document );

The editor is not being called in any cross domain capacity and as I said, it happens infrequently. Frequency of the issue is increased if the "Disable Cache" option of the Firefox "Web Dev Toolbar" plugin is enabled. This option only sets preferences built into firefox so it is not at fault.

The preferences it changes are:

'browser.cache.disk.enable' 'browser.cache.memory.enable'

Tested Browser is FF 3.6.17

Change History (10)

comment:1 Changed 8 years ago by Freddie Bingham

Summary: Permission Denied to get propety Window.documentPermission Denied to get property Window.document

comment:2 Changed 8 years ago by Jakub Ś

Status: newpending

I'm not sure if I understand you correctly. You say that you place a link in CKEditor editing area and when page loads you get permission denied?

I did not get that result.

Could you provide me with more info, a simplified test case perhaps?

comment:3 Changed 8 years ago by Freddie Bingham

Nothing to do with a link, doesn't matter if the editor begins with data or not. It doesn't happen very often but it does happen. The Permission denied for < http://www.example.com> to get property Window.document is quite a telling error. I will have to add a timeout and retry there to see if it works.

comment:4 Changed 8 years ago by Jakub Ś

I have setup domain www.example.com, disabled cache in Web developer toolbar and loaded page with CKE (many, many times) but no permission denied was thrown.

Is this how you got this error and if not could you describe a step by step scenario?

Also is it possible to provide us with a sample HTML file which can help to reproduce the issue?

comment:5 Changed 8 years ago by Jakub Ś

@fbingha any updates regarding this issue?

comment:6 Changed 8 years ago by Jakub Ś

@fbingha any updates regarding this issue?

comment:7 Changed 8 years ago by Freddie Bingham

The only update that I have is that this is happening randomly when the page is also including the facebook connect api and/or a facebook like button.

comment:8 Changed 8 years ago by Jakub Ś

And could I ask you to provide reduced test case for this (file/files/sample application)?

I have tried to reproduce it few times but had no luck and you know best what is wrong and how to repeat it.

comment:9 Changed 8 years ago by Freddie Bingham

You can close this bug as I have tracked down the cause to duplicate facebook elements with the same ID of "fb-root". In some odd way this caused the facebook like button iframe init to stop the the CKEditor iframe from initializing properly.

comment:10 Changed 8 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy