Opened 8 years ago

Closed 8 years ago

#7922 closed Bug (fixed)

Can't open dialogs in IE6

Reported by: Jakub Ś Owned by: Sa'ar Zac Elias
Priority: Normal Milestone: CKEditor 3.6.1
Component: General Version: 3.6.1
Keywords: IE6 IBM Cc: satya_minnekanti@…

Description (last modified by Jakub Ś)

When opening dialogs in IE6, JS error pops out:

Line:3127
Message: [CKEDITOR.dialog.openDialog] Dialog “link” failed when loading definition
URI: /_source/plugins/dialog/plugin.js

This has occured from revision [6971]

Attachments (3)

IE6_ajax.png (33.2 KB) - added by Jakub Ś 8 years ago.
IE6 ajax2.png (27.3 KB) - added by Jakub Ś 8 years ago.
7922.patch (578 bytes) - added by Sa'ar Zac Elias 8 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 8 years ago by Jakub Ś

Description: modified (diff)
Status: newconfirmed

comment:2 Changed 8 years ago by Sa'ar Zac Elias

Milestone: CKEditor 3.6.1

comment:3 Changed 8 years ago by Sa'ar Zac Elias

Status: confirmedpending

I'm unable to reproduce the problem, are there any more details on this?

comment:4 Changed 8 years ago by Jakub Ś

Maybe some IE6 caching fooled me because I thought that this is happening "by default" and after some investigation it seems that this issue has similar TC to #7919.

  1. Open Ajax sample
  2. Clear browser cache
  3. Create an editor
  4. Open any dialog from toolbar

Result: Error pops out (see IE6 ajax2.png).

It looks like IE6 is not loading everything when editor is created. Sometimes instead of error only contents are shown (see IE6 ajax.png).

What is strange is that I could not reload the cache using CRTL+F5. To get dialogs working again I have opened replaceEmenetsByClass sample tried out few dialogs (they worked there) and then came back to Ajax sample.

If this helps I have tested it on Windows XP 2002 SP2 and IE 6.0.2900.2180_xpsp2_gdr.100216-1441

Changed 8 years ago by Jakub Ś

Attachment: IE6_ajax.png added

Changed 8 years ago by Jakub Ś

Attachment: IE6 ajax2.png added

comment:5 Changed 8 years ago by Satya Minnekanti

Cc: satya_minnekanti@… added

comment:6 Changed 8 years ago by Satya Minnekanti

Keywords: IBM added

comment:7 Changed 8 years ago by Sa'ar Zac Elias

Status: pendingconfirmed

I was able to reproduce the problem running from a server.

Changed 8 years ago by Sa'ar Zac Elias

Attachment: 7922.patch added

comment:8 Changed 8 years ago by Sa'ar Zac Elias

Owner: set to Sa'ar Zac Elias
Status: confirmedreview

comment:9 Changed 8 years ago by Frederico Caldeira Knabben

Status: reviewreview_passed

comment:10 Changed 8 years ago by Sa'ar Zac Elias

Resolution: fixed
Status: review_passedclosed

Fixed with [6990].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy