Opened 11 years ago

Closed 10 years ago

Last modified 9 years ago

#7943 closed Bug (fixed)

Label Style should have float:none

Reported by: Charlie Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 3.6.2
Component: UI : Skins Version: 3.6
Keywords: Cc:

Description

This problem arises when the containing page has a style on the label element of float: left (or right);

I've attached a picture for clarity from one of the samples (Obviously I added the float on the label). I think we want to provide a standard experience in CKEditor regardless of CSS on the containing page (at least by default!), so I propose adding an entry:

.cke_dialog label {

float: none;

}

to each of the skins dialog.css files

Thoughts?

Attachments (2)

pic.jpg (336.7 KB) - added by Charlie 11 years ago.
illustration of problem
7943.patch (1.2 KB) - added by Frederico Caldeira Knabben 11 years ago.

Download all attachments as: .zip

Change History (14)

Changed 11 years ago by Charlie

Attachment: pic.jpg added

illustration of problem

comment:1 Changed 11 years ago by Charlie

Version: 3.63.6.1 (SVN - trunk)

Tested in nightly as well.

comment:2 in reply to:  1 Changed 11 years ago by Frederico Caldeira Knabben

Component: UI : DialogsUI : Skins
Keywords: label dialog css removed
Version: 3.6.1 (SVN - trunk)3.6

Replying to comp615:

The "version" field is there to tell us the oldest version that presents this problem.

comment:3 in reply to:  description ; Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Discussion added
Status: newconfirmed

Replying to comp615:

I think we want to provide a standard experience in CKEditor regardless of CSS on the containing page (at least by default!)

Your totally right... but this is a very difficult thing.

We use the reset.css for this. What we do is a deal, trying to reset the most commonly used CSS rules that could be used. But of course, CSS is so extensive that it's hard to deal with everything.

So, what should be our position here? Keep enlarging reset.css by user request? Providing instructions on how to workaround this situation (the above rule, which you have included into dialog.css, should go into your own CSS file at this point).

comment:4 in reply to:  3 Changed 11 years ago by Frederico Caldeira Knabben

Replying to fredck:

Keep enlarging reset.css by user request?

We have so few requests for this (so far), that I think that this would be ok.

In this specific case... would float:none on reset.css cause problems?

comment:5 Changed 11 years ago by Charlie

I don't think so? It should have the same effect as putting it in the other place. Additionally that is the default behavior (with no CSS rules right?). As I kind of alluded to (and I think you corroborated) the idea is to provide CKEditor the base CSS to start building up from, so I think your solution is perfect.

And of course, it is very hard to deal with everything, but in the end I think that is the goal is to reset as much as possible so that CKEditor works on virtually any page you could throw at it.

comment:6 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Discussion removed
Owner: set to Frederico Caldeira Knabben
Status: confirmedassigned

Having a huge reset.css file doesn't make sense either. So, let's go ahead by enlarging it when necessary.

Changed 11 years ago by Frederico Caldeira Knabben

Attachment: 7943.patch added

comment:7 Changed 11 years ago by Frederico Caldeira Knabben

Status: assignedreview

comment:8 Changed 11 years ago by Frederico Caldeira Knabben

I've checked the standard html.css file used by Firefox. Resetting float:none should not bring any issue for our UI.

comment:9 Changed 10 years ago by Sa'ar Zac Elias

Status: reviewreview_passed

comment:10 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.6.2
Resolution: fixed
Status: review_passedclosed

Fixed with [7185].

comment:11 Changed 9 years ago by FrankSL

Version: 3.64.0.1

I'm resetting this bug because it happens to me in 4.0.1, I just added a <style> tag in a simple page with framed editor like this:

<style type="text/css">
    label,select,.ui-select-menu { float: left; margin-right: 10px; font-size:1.3em; height:26px; line-height:26px; font-size:1em; }
</style>

it makes all the labels in ckeditor dialogs to be floated. Thanks

comment:12 Changed 9 years ago by Jakub Ś

Version: 4.0.13.6

@FrankSL I have reported #10175 for CKE 4

Note: See TracTickets for help on using tickets.
© 2003 – 2021 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy