Opened 4 years ago

Closed 4 years ago

#7993 closed Bug (fixed)

Error suggestion not correct when we enter invalid values for Cell spacing & Cell padding fields in Table dialog

Reported by: satya Owned by: Anna
Priority: Normal Milestone: CKEditor 3.6.1
Component: General Version: 3.0
Keywords: IBM Cc: damo, tmonahan

Description

To reproduce the defect:

In the Table Properties enter invalid values(-20 or 35ex) for Cell spacing and press OK button.

Expected Result: An error dialog comes up with a waring message Cell spacing must be a positive number.

Actual Result: An error dialog comes up with a waring message Cell spacing must be a number

we should clearly mention in the Error message that that user should use positive numbers.

same issue when we enter invalid value for Cell padding

This is not satisfying the criteria for A11y Checkpoint 3.3

Attachments (1)

7993.patch (590 bytes) - added by Anna 4 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 follow-up: Changed 4 years ago by j.swiderski

  • Status changed from new to confirmed
  • Version set to 3.0

comment:2 in reply to: ↑ 1 Changed 4 years ago by satya

  • Version changed from 3.0 to 3.6.1 (SVN - trunk)

Replying to j.swiderski:

@j.swiderski Correct Error Message shown in 3.6 & message was changed only in 3.6.1.

In 3.6 Error Message is Cell spacing must be a positive number.

In 3.6.1 Error Message is Cell spacing must be a number.

comment:3 follow-up: Changed 4 years ago by wwalc

@satya - is it possible that you have modified your local copy of en.js? invalidCellSpacing string was set to 'Cell spacing must be a number.' in CKEditor 3.6.

http://dev.ckeditor.com/browser/CKEditor/releases/latest/_source/lang/en.js#L274

comment:4 in reply to: ↑ 3 Changed 4 years ago by satya

Replying to wwalc:

@satya - is it possible that you have modified your local copy of en.js? invalidCellSpacing string was set to 'Cell spacing must be a number.' in CKEditor 3.6.

http://dev.ckeditor.com/browser/CKEditor/releases/latest/_source/lang/en.js#L274

@wwalc I have spoken to our dev team and they confirmed that we modified our local copy of en.js file They informed me that they will fix it in our internal builds,but it's always nice to be fixed on your end with corect suggestion. so we will leave the ticket open.

comment:5 Changed 4 years ago by wwalc

  • Milestone set to CKEditor 3.6.1
  • Version changed from 3.6.1 (SVN - trunk) to 3.0

Definitely makes sense, just wanted to make sure it's not a regression. It's a simple change so let's have it in 3.6.1.

Changed 4 years ago by Anna

comment:6 Changed 4 years ago by Anna

  • Owner set to Anna
  • Status changed from confirmed to review

Since it is that simple, I will gladly become the owner of my very first ticket and put the "patch" on review ;)

comment:7 Changed 4 years ago by wwalc

  • Status changed from review to review_passed

Let's correct it also in other languages where we are able to do it.

comment:8 Changed 4 years ago by Anna

  • Resolution set to fixed
  • Status changed from review_passed to closed

Fixed with [7025].

Note: See TracTickets for help on using tickets.
© 2003 – 2015 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy