Opened 8 years ago

Closed 8 years ago

#8006 closed Bug (duplicate)

FF4 Ubuntu: right click between tables in wysiwyg mode results in an error

Reported by: Flavien CROCHARD Owned by:
Priority: Normal Milestone:
Component: General Version: 3.3.2
Keywords: Firefox4 Cc:

Description (last modified by Wiktor Walc)

Depends of the content in the editor.

Steps to reproduce

  1. Load contents of attached sample.txt.
  2. Click between the second and the third table (click few times in random places to trigger the error - it happens randomly).
  3. The following errors appear:
    target.getOuterHtml is not a function
    if ( !target.getOuterHtml().replace( emptyParagraphRegexp, '' ) ) 
    _source/plugins/wysiwygarea/plugin.js Line 668
    
    ev.getTarget().is is not a function
    if ( ev.getTarget().is( 'a' ) && ev.$.button != 2 ) 
    _source/plugins/wysiwygarea/plugin.js Line 682
    

Whenever the JS error occurs, target is set to "document" instead of "p".

Can be reproduce at least since CKEditor 3.3.2.

Attachments (2)

sample.txt (2.4 KB) - added by Flavien CROCHARD 8 years ago.
log.png (139.9 KB) - added by Flavien CROCHARD 8 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 8 years ago by Frederico Caldeira Knabben

Yes, please let us know what exactly we need to have in the editor, as well as the right place to click. Thanks!

Changed 8 years ago by Flavien CROCHARD

Attachment: sample.txt added

comment:2 Changed 8 years ago by Flavien CROCHARD

Here is a sample document. Just click between two tables, and you'll get the error. Thanks for your help.

comment:3 Changed 8 years ago by Wiktor Walc

Status: newpending

In which browser/OS do you see the error? Where exactly we should click? What exactly version of CKEditor are you using? I've tried to reproduce it in IE8 and Safari without luck.

comment:4 Changed 8 years ago by Flavien CROCHARD

With Firefox 4.01 and ckeditor retrieved from svn. And a right click between the first and the second table. A js error is catched with firebug.

Last edited 8 years ago by Flavien CROCHARD (previous) (diff)

comment:5 Changed 8 years ago by Wiktor Walc

I'm still unable to reproduce it, works for me in Firefox 4.0.1 / Win XP, both in the nightly build and in CKEditor 3.6.

comment:6 Changed 8 years ago by Flavien CROCHARD

Ok, so here is a screenshot : i included the mouse pointer so you can see the position and the error log produced. Well, i am with an Ubuntu 11.04 x86_64. Maybe it is usefull to know that. Thanks in advance.

Changed 8 years ago by Flavien CROCHARD

Attachment: log.png added

comment:7 Changed 8 years ago by Wiktor Walc

Description: modified (diff)
Keywords: Firefox4 added
Resolution: duplicate
Status: pendingclosed
Summary: right click in wysiwyg mode with firefoxFF4 Ubuntu: right click between tables in wysiwyg mode results in an error
Version: 3.6.1 (SVN - trunk)3.3.2

Thanks flavien for helping me in reproducing it. Indeed I managed to confirm it on Ubuntu.

We have a very similar bug reported in #7856 so I'm marking this one as duplicate.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy