Opened 10 years ago

Closed 10 years ago

#8036 closed Bug (fixed)

Inconsistent handling of height and width values

Reported by: Sa'ar Zac Elias Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.6.1
Component: UI : Dialogs Version: 3.6.1
Keywords: Cc: satya_minnekanti@…

Description

  • Insert an iframe with width=200, height=300.
  • RMB on it, open the iframe dialog. See that it shows width=200px, height=300px.
  • Switch to source and back.
  • RMB on the iframe, open the iframe dialog. See that now it shows width=200, height=300.

Attachments (1)

8036.patch (16.1 KB) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 10 years ago by Garry Yao

Owner: set to Garry Yao
Status: newassigned

Regression of [7012].

Changed 10 years ago by Garry Yao

Attachment: 8036.patch added

comment:2 Changed 10 years ago by Garry Yao

Affects also Flash dialog.

comment:3 Changed 10 years ago by Garry Yao

Status: assignedreview

After [6979], pixel-based size could come in two equivalent forms in either a single number or with the 'px' unit, editor should respect both forms specified by user on dialog operations, re-sizing as well as on data output.

Patch includes also the fix for #8038

comment:4 Changed 10 years ago by Satya Minnekanti

Cc: satya_minnekanti@… added

comment:5 Changed 10 years ago by Sa'ar Zac Elias

Status: reviewreview_failed

Actually when dimensions are specified via styles, these are the ones to use, as per browsers rendering.

comment:6 Changed 10 years ago by Sa'ar Zac Elias

Sorry, that was not related to the patch.
The two forms should be distinguished on input as well, as currently width="200px" is (wrongly) converted into width="200".
And a small one, please fix coding style in the new htmlParser::cssStyle codes.

comment:7 Changed 10 years ago by Garry Yao

Status: review_failedreview

This turns out to be an IE limitation instead, where the DOM swallows the "px" units on attributes, works well for all the rest of browsers, we can hardly fix it.

comment:8 Changed 10 years ago by Sa'ar Zac Elias

Status: reviewreview_passed

Make sure to fix coding style in the new htmlParser::cssStyle codes before committing.

comment:9 Changed 10 years ago by Garry Yao

Resolution: fixed
Status: review_passedclosed

Fixed with [7050:7051].

Note: See TracTickets for help on using tickets.
© 2003 – 2021 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy