Opened 12 years ago

Closed 12 years ago

#806 closed Bug (duplicate)

Format text changes entire page not just highlighted text in IE.

Reported by: metronome Owned by:
Priority: Normal Milestone:
Component: Core : Styles Version: FCKeditor 2.4.2
Keywords: Cc: Robert de Jong

Description

In IE when I select some text and pick an option from the Format drop down list all of the text changes on the page not just the selected text. In firefox it seems that only the selected text is changed. However I'm required to use IE :(

Change History (4)

comment:1 Changed 12 years ago by Alfonso Martínez de Lizarrondo

Component: GeneralCore : Styles
Milestone: FCKeditor 2.5

#955 has been marked as dup

This should be addressed with the new Style system, so let's put it in the radar.

comment:2 Changed 12 years ago by Frederico Caldeira Knabben

Cc: Robert de Jong added
Keywords: Pending added
Milestone: FCKeditor 2.5

It works for me with the SVN version and IE7. Please provide us step by step instructions to reproduce the problem here using the nightly build. Thanks in advance.

comment:3 Changed 12 years ago by redthor

I think this has been around awhile. I've tried it in FCKeditor 2.3.2 and 2.2 as well as the nightly build. http://www.fckeditor.net/forums/viewtopic.php?f=6&t=6496&start=0&st=0&sk=t&sd=a

comment:4 Changed 12 years ago by Frederico Caldeira Knabben

Keywords: Pending removed
Resolution: duplicate
Status: newclosed

As far as I understood it, this issue is related to the problem of applying a block style to the selection.

Block styles, are today applied to the selected blocks, even if partially selected. That's the expected behavior.

We instead have a problem when EnterKey='br', because in this case our blocks are actually lines separated by a <br>. In this case, everything changes to the format selected (in IE). For this one we already have #68, so I'm considering this ticket as a DUP.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy