Opened 8 years ago

Closed 6 years ago

#8060 closed Bug (wontfix)

[IE Quirks] Dialog min-width/height doesn't work

Reported by: Garry Yao Owned by:
Priority: Normal Milestone:
Component: UI : Dialogs Version: 3.4.3
Keywords: HasPatch Cc:

Description

When content size exceeds specified minimum dimension, dialog body is not automatically stretched in IE quirks, e.g. "fr" language + table cell dialog.

Attachments (4)

8060.patch (3.1 KB) - added by Garry Yao 8 years ago.
result.png (8.6 KB) - added by Jakub Ś 7 years ago.
ckeditor_anchor.png (3.7 KB) - added by Jakub Ś 7 years ago.
replace_option_IE8.png (8.7 KB) - added by Jakub Ś 7 years ago.

Download all attachments as: .zip

Change History (11)

Changed 8 years ago by Garry Yao

Attachment: 8060.patch added

comment:1 Changed 8 years ago by Garry Yao

Keywords: HasPatch added

comment:2 Changed 8 years ago by Jakub Ś

Status: newconfirmed
Version: 3.4.3

This issue looks like a DUP of #8028

I will confirm this one as it contains patch.

Confirmed for all IEs in Quirks mode.

comment:3 Changed 7 years ago by Jakub Ś

Owner: set to Jakub Ś
Status: confirmedreview

Changed 7 years ago by Jakub Ś

Attachment: result.png added

comment:4 Changed 7 years ago by Jakub Ś

Status: reviewreview_failed

Patch fixes dialogs like anchor mentioned in ticket #8028

but it breaks dialogs like iFrame, Find and Link in IE8 and IE9.

When you first open dialog (after clearing the cache) top elements will be overflow (see result.png). Everything gets back to normal after you hover over dialog for few seconds. Another problem is that once the layout is ok the cancel button may disappear.

Last edited 7 years ago by Jakub Ś (previous) (diff)

Changed 7 years ago by Jakub Ś

Attachment: ckeditor_anchor.png added

Changed 7 years ago by Jakub Ś

Attachment: replace_option_IE8.png added

comment:5 Changed 7 years ago by Jakub Ś

Please also note that without this patch find dialog look like this:

But this is rather the result of rev. [7179] mentioned in #9125.

Last edited 7 years ago by Jakub Ś (previous) (diff)

comment:6 Changed 7 years ago by Jakub Ś

Owner: Jakub Ś deleted
Status: review_failedconfirmed

comment:7 Changed 6 years ago by Piotrek Koszuliński

Resolution: wontfix
Status: confirmedclosed

Kama's support finished and these issues are not reproducible on Moono skin.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy