Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#8074 closed Bug (worksforme)

FF: Editor scrolls up when selecting text

Reported by: Jakub Ś Owned by:
Priority: Normal Milestone: CKEditor 3.6.3
Component: General Version: 3.4.2
Keywords: Firefox Cc:

Description

This issue is based on http://drupal.org/node/1096164.

To reproduce:

  1. Include in your CKEditor HTML page and CSS file from the attachment.
  2. Open sample page
  3. Scroll down to the middle of the editor
  4. Select some text but try to start somewhere in blank area. Clicking in area next to "Little Red Riding Hood" always works.

Result:
Editor scrolls up.

The reason is that body in contents.css has height:100% applied. This particular setting is causing the whole problem.

I have managed to reproduce the issue only on Firefox (One user claimed that he reproduced it in IE8) browser from CKEditor 3.4.2

Attachments (1)

tc.zip (3.5 KB) - added by Jakub Ś 6 years ago.

Download all attachments as: .zip

Change History (6)

Changed 6 years ago by Jakub Ś

Attachment: tc.zip added

comment:1 Changed 6 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 6 years ago by Garry Yao

Supposed to be fixed by #7932.

comment:3 Changed 6 years ago by Jakub Ś

I did a quick test and it seems that patch from #7932 has fixed this issue.

comment:4 Changed 6 years ago by Frederico Caldeira Knabben

Resolution: worksforme
Status: confirmedclosed

comment:5 Changed 6 years ago by Wiktor Walc

Milestone: CKEditor 3.6.3
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy