Opened 8 years ago

Closed 5 years ago

#8121 closed Bug (fixed)

Placeholder plugin messes the content of textareas

Reported by: Alfonso Martínez de Lizarrondo Owned by:
Priority: Normal Milestone:
Component: Core : Parser Version: 3.0
Keywords: Cc:

Description

This is more exactly a problem with the dataProcessor system, but this is the easiest way to reproduce it:

  1. Load the placeholder sample.
  2. Switch to source and add a textarea with a value that includes code that matches the placeholder syntax:
    <textarea cols='80' rows='8' name='test'>[[sample placeholder]].</textarea>
    
  3. Switch to design.

Expected results: the contents of the textarea are shown unmodified

Actual results: the textarea shows this content:

<span class="cke_placeholder" data-cke-placeholder="1" contenteditable="false">[[sample placeholder]]</span>.

And it will get worse everytime you switch to source and back to design.

The problem is that the placeholder plugin acts on the dataFilter 'text' filter, but the content of the textarea isn't text in the same way that it happens in other elements and it should perform the conversion in this situation.

Don't know right now what's the correct solution, maybe a second parameter to the 'text' filter specifying the element where this content is present?

The problem can be reproduced this way since the placeholder plugin was introduced, but the issue itself has been present since the beginning if someone used his own plugin to deal with 'text'

Change History (2)

comment:1 Changed 8 years ago by Jakub Ś

Status: newconfirmed

The placeholder plug-in was introduced in CKE 3.5 but based on what @alfonsoml has written I'm leaving the version as 3.0.

comment:2 Changed 5 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

This issue was fixed around CKEditor 4.1.0-4.1.2.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy