Opened 8 years ago

Closed 7 years ago

#8125 closed Bug (duplicate)

'font size' and 'font name' are wrongly applied to selected text in XHTML sample

Reported by: Jakub Ś Owned by:
Priority: Normal Milestone:
Component: General Version: 3.2.2
Keywords: Cc:

Description

  1. Open XHTML sample in any browser
  2. Select sample text with a mouse
  3. Choose size ‘Double' from font-size combo
  4. Now choose font size ‘Smaller’ - you will see that text gets smaller but not as small as it normally does. What is more the ‘Double’ option in font-size is still selected.
  5. Choose font size ‘8pt’ and then ‘14pt’ you will see no change of the font size. What is more the ‘Double’ option in font-size is still selected.
  6. Now deselect the ‘Double’ option. You will see that ‘Smaller’ will be selected.
  7. Deselecting ‘Smaller’ causes ‘8pt’ to get selected
  8. Deselecting ‘8pt’ causes ‘14pt’ to get selected.
  9. The same thing is applicable for font name combo

This issue is reproducible from CKEditor 3.2.2.

In CKE 3.2.1 you could select font-size or font-name only once. After that no matter what you click font size or name won’t change.

Change History (3)

comment:1 Changed 8 years ago by Jakub Ś

Here is HTML code produced by CKE:

<p>
	<span class="FontBig">
		<span class="FontSmall">
			<span class="FontSmaller">
				<span class="FontDouble">
					This is some <span class="Bold">sample text</span>. You are using <a href="http://ckeditor.com/" data-cke-saved-href="http://ckeditor.com/">CKEditor</a>.
				</span>
			</span>
		</span>
	</span>
<br type="_moz">
</p>

As you can see, new font sizes/names are added instead of being replaced.

Every time you click currently selected item from combo box (most inner span) its span representation will get removed and next most inner span in line will take its place.

Last edited 8 years ago by Jakub Ś (previous) (diff)

comment:2 Changed 8 years ago by Jakub Ś

Status: newconfirmed

comment:3 Changed 7 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed

This is actually a duplicate of #7498

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy