Opened 8 years ago

Closed 8 years ago

#8223 closed Bug (expired)

Disabling the Advanced tab for links causes "undefined" to be assigned to the name attribute

Reported by: David Colon Owned by:
Priority: Normal Milestone:
Component: UI : Dialogs Version:
Keywords: Cc:

Description

When disabling the Advanced tab for links using the following:

CKEDITOR.on('dialogDefinition', function (ev) {
    var dialogName = ev.data.name;
    var dialogDefinition = ev.data.definition;

    if (dialogName == 'link' || dialogName == 'image') {
        dialogDefinition.removeContents('advanced');
    }
});

The name attribute is being assigned to any edited links as "undefined". This causes the yellow anchor image to be displayed next to the link, causing our users some confusion.

Attachments (1)

config.js (2.8 KB) - added by David Colon 8 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 8 years ago by Jakub Ś

Status: newpending

I have tried your code but no name attribute with undefined value was added. I have probably missed something.

Could you:

  1. Tell me in which browser does the issue occur?
  2. In which operating system?
  3. Are there any other CKEditor custom settings that you are using that might cause this error?

Perhaps it would be best if you could provide us with a sample file showing the problem and/or a step by step scenario to reproduce it.

Waiting for your feedback.

Changed 8 years ago by David Colon

Attachment: config.js added

comment:2 Changed 8 years ago by David Colon

This is happening on IE9 running on Windows 7 Ultimate. I have attached our config.js. Also note that we have just integrated CKFinder into CKEditor, in case that has something to do with it.

comment:3 Changed 8 years ago by Jakub Ś

I have double checked but still no luck.

Here is what I did:

  1. I have used your config file (used it for CKEditor standalone and integrated with CKFinder).
  2. Opened sample page and inserted a link.
  3. Then I have edited the link and checked it in source mode.

No name attributes were added.

Have I missed something in the above steps?

I have noticed that you are using custom 'GSIHelp'. Have you tried to run your application without it to find out if it isn’t the source of the problem?

Is the issue reproducible in clean CKEditor or only within your application? Because if that’s the case than maybe some custom application settings might be causing this?

Perhaps there is one more thing. Could you tell me if you are using Plain JS version of CKEditor or one of integrations like Java or PHP?

comment:4 Changed 8 years ago by Jakub Ś

@davidiq are there any updates regarding this issue?

comment:5 Changed 8 years ago by David Colon

Have not been able to get back to this, sorry. Will get to it next week.

comment:6 Changed 8 years ago by Jakub Ś

@davidiq is the issue still reproducible? If so would you be so kind to answer my questions co that we were able reproduce the issue?

Have you verified that this issue has nothing to do with your custom plugin or custom application settings?

comment:7 Changed 8 years ago by Jakub Ś

Keywords: Advanced Link Anchor removed
Version: 3.6.1

comment:8 Changed 8 years ago by Jakub Ś

Resolution: expired
Status: pendingclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy