Opened 8 years ago

Closed 5 years ago

Last modified 5 years ago

#8224 closed Bug (fixed)

IE : scayt AutoStartUp and EnterMode BR moves cursor to the beginning.

Reported by: Jakub Ś Owned by:
Priority: Normal Milestone:
Component: UI : Spell Checker Version: 3.4.3
Keywords: Review? Cc: WebSpellChecker.net

Description

  1. Place attached file in sample folder. It contains only two settings:
    var e = CKEDITOR.replace( 'editor1', {
    scayt_autoStartup:true,					
    enterMode : CKEDITOR.ENTER_BR					
    });
    
  2. Open it in IE8 (wait a second until everything loads)
  3. Select whole sample text with a mouse and delete it using BACKSPACE
  4. type "how"

Result: it will be typed as "owh". That is it will be typed as ‘owh” if you type it with regular speed. If you type h, wait until cursor moves to the beginning, type o, than wait again, type w, you will get “woh”.
To sum up if you type a letter and wait the cursor will be moved to the beginning.

Issue has been reproducible in IE8 only from CKE 3.5.3

Attachments (1)

8224.html (1.2 KB) - added by Jakub Ś 8 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 8 years ago by Jakub Ś

Status: newconfirmed

Changed 8 years ago by Jakub Ś

Attachment: 8224.html added

comment:2 Changed 8 years ago by Jakub Ś

Perhaps this issue is related to #7806

comment:3 Changed 8 years ago by Jakub Ś

Keywords: IE added; IE8 removed
Summary: IE8 : scayt AutoStartUp and EnterMode BR moves cursor to the beginning.IE : scayt AutoStartUp and EnterMode BR moves cursor to the beginning.
Version: 3.5.33.4.3

I have checked the issue one more time.

It is reproducible in all IEs not only in IE8. Also the version was incorrect. The bug has started occurring from CKE 3.4.3

comment:4 Changed 8 years ago by WebSpellChecker.net

Keywords: Review? added; IE removed

Fixed in SCAYT Core from v2.7.0 (1431)

comment:5 Changed 6 years ago by Wiktor Walc

Component: GeneralUI : Spell Checker

comment:6 Changed 5 years ago by Wiktor Walc

Resolution: fixed
Status: confirmedclosed

comment:7 Changed 5 years ago by Wiktor Walc

(unable to reproduce in IE8 using the attached sample)

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy