Opened 4 years ago

Closed 2 years ago

#8276 closed Bug (fixed)

Opera: cursor goes to start of editor body when we apply text/background colour

Reported by: satya Owned by:
Priority: Normal Milestone:
Component: General Version: 3.4
Keywords: IBM Opera Cc: damo, tmonahan

Description

To reproduce the defect:

  1. Open any sample, type some text, keep cursor at the end of paragraph.
  1. Click on text color combo and select a text color.

Expected Result: Cursor stays at the end of paragraph and when we type the text Text color gets applied to the newly typed text.

Actual Result: Cursor moves to start of editor body(i.e. first paragraph)

  1. Move cursor to end of paragraph where we were before in step 1 and start typing the text

Expected Result Text color applied to the typed text.

Actual Result Text color not applied to the typed text.

Same issue happens when we apply background color

Change History (3)

comment:1 Changed 4 years ago by j.swiderski

  • Keywords Opera added
  • Status changed from new to confirmed
  • Version set to 3.4

Reproducible from CKE 3.4

comment:2 Changed 2 years ago by tmonahan

We can no longer reproduce this with Opera 12. Perhaps this was a browser issue that is now resolved.

comment:3 Changed 2 years ago by j.swiderski

  • Resolution set to fixed
  • Status changed from confirmed to closed

It seems to be working fine in latest Opera 12.16.

Note: See TracTickets for help on using tickets.
© 2003 – 2015 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy