Opened 8 years ago

Closed 5 years ago

#8294 closed Bug (fixed)

IE: Copied and Pasted content gets wrapped in <b>, <u>, <i> or <span> tags

Reported by: Jakub Ś Owned by:
Priority: Normal Milestone:
Component: Core : Pasting Version: 3.1
Keywords: IE Cc: leungmwk@…

Description

This ticket was reported by @Ken in our support channel (Topic:” Request for support: content incorrectly display”)

  1. Open any editor sample and switch to source
  2. Clear everything
  3. Paste in the following code:

Example 1:

<p>
	<i><u><b><span style="font-size: 16pt"><span style="font-family: arial">Simple testing sample for all features, </span></span></b></u></i></p>
<p>
	<span style="font-size: 16pt"><span style="font-family: times new roman">font <span style="color: #ff0000">family, </span></span></span></p>
<p>
	End .</p>

Example 2:

<p>
	<span style="font-size: 16pt"><span style="font-family: times new roman">font <span style="color: #ff0000">family, </span></span></span></p>
<p>
	End .</p>
<p>
	<i><u><b><span style="font-size: 16pt"><span style="font-family: arial">Simple testing sample for all features, </span></span></b></u></i></p>
  1. Switch back to WYSIWYG mode
  2. Press CRTL+A, CRTL+C, CRTL+V

Result: All insights of paragraphs get wrapped in i,u,b (Example 1) or span (Example 2) tags.

Issue has been reproducible in IE browsers from CKE 3.1.

Change History (5)

comment:1 Changed 8 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 7 years ago by Frederico Caldeira Knabben

Component: GeneralCore : Pasting

comment:3 Changed 7 years ago by Jakub Ś

This is because all paragraphs are pasted in span. When you switch to source and back CKEditor tries to fix it but proper behaviour is that content should not be pasted into span but below it.

comment:4 Changed 7 years ago by Jakub Ś

The same root of the problem (pasting block into inline in IE) is applicable for other tickets: #8736, #9207, #9740. I think they all can be fixed with one patch.

Last edited 6 years ago by Jakub Ś (previous) (diff)

comment:5 Changed 5 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

Not reproducible since CKEditor 4.0. We implemented completely custom insert HTML method.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy