Opened 7 years ago

Closed 6 years ago

#9207 closed Bug (fixed)

Source duplicates template background in IE

Reported by: Sebastian Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: IE Cc: amol.kawale@…

Description (last modified by Jakub Ś)

Ticket REF : 6557-USFL-1340 | Ticket ID : 6730

  • Add "Strange Template" template to text area
  • Select all in text area (CERTL+A) and add a background color to template content
  • Put cursor at the end of content (More text goes here.^)
  • Add a new template to text area and make sure "Replace actual contents" is unselected

Results:

  • You have two templates with background colour IE6-8
  • Or one with a background colour, one without (IE9) but once you click on Source then click Source again to go back to WYSIWYG mode the second template will get the background of the first. This only happens in IE9.

It seems that in IE9 block content is not being styled when it is pasted inside span.

Attachments (1)

Instructions-2-IE.doc (744.5 KB) - added by Sebastian 7 years ago.

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by Sebastian

Attachment: Instructions-2-IE.doc added

comment:1 Changed 7 years ago by Jakub Ś

Description: modified (diff)
Status: newconfirmed
Version: 3.0

comment:2 Changed 7 years ago by Jakub Ś

Description: modified (diff)

This is happening because second template (all tags) is pasted into span. When you switch to source and back CKEditor tries to fix the code and wraps every single element inside template in span.

The same root of the problem (pasting block into inline in IE) is applicable for other tickets: #8736, #8294, #9740. I think they all can be fixed with one patch.

Last edited 7 years ago by Jakub Ś (previous) (diff)

comment:3 Changed 7 years ago by Jakub Ś

#10424 was marked as duplicate.

comment:4 Changed 6 years ago by Jakub Ś

Resolution: fixed
Status: confirmedclosed

This issue seems no longer reproducible in latest CKEditor 4.x. I'm closing it as fixed.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy