Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#9206 closed Bug (invalid)

Undeletable p-tag after quitting enumerations with backspace

Reported by: Ferdinand Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc: fzirker@…

Description

Create a unnumbered list Create a few list items Hit ENTER to create a new empty enumeration item Hit BACKSPACE to leave the enumeration. Write some fancy stuff.

If you view the HTML source, you see that there is a <p> tag too much. In most browsers this is fine, but in IE8 in IE7 compatibility mode, an undeletable (you can't click the line) paragraph is between the enumeration and the fancy stuff. See Screenhost in attachment.

Attachments (1)

pHtmlTagTooMuch.png (143.0 KB) - added by Ferdinand 7 years ago.

Download all attachments as: .zip

Change History (9)

Changed 7 years ago by Ferdinand

Attachment: pHtmlTagTooMuch.png added

comment:1 Changed 7 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
Version: 3.6.2

This is enter mode dependent: http://docs.cksource.com/ckeditor_api/symbols/CKEDITOR.config.html#.enterMode.

By default CKEditor wraps text in paragraphs. This is recommended setting.
If you think paragraphs are too big you can add style for paragraphs in contents.css (this is only for content area in editor).

Of course your result page will need to have these styles implemented as well.

comment:2 Changed 7 years ago by Ferdinand

The additional p-tag is only created by IE and when quitting the list with BACKSPACE. Thus CKEditor doesn't wrap text in paragraphs always. So it looks to me like a browser specific bug.

Maybe enterMode will be a workaround, i will try. Anyhow, a wrong html source is generated under certain circumstances described above.

comment:3 Changed 7 years ago by Ferdinand

The enterMode already was configured as BR.

The bug happens when hitting BACKSPACE (and not ENTER). Maybe that's why enterMode config doesn't have influence.

comment:4 Changed 7 years ago by Jakub Ś

How do you escape a list with backspace?

The only known way to me is hitting enter two times (first will create empty element second will remove it and create new line behind the list).

Could you please provide exact and detailed steps to recreate this problem (step by step scenario). Also if this is possible please provide a screen cast for this scenario.

comment:5 Changed 7 years ago by Ferdinand

You can escape a list using BACKSPACE when using IE 7 or 8 (and there is no text behind the current dot).

Hitting ENTER two times work fine. Unfortunately, my audience keeps using BACKSPACE :-)

A step by step scenario is in the initial description of this issue. I will see if i can provide a screencast.

comment:6 Changed 7 years ago by Jakub Ś

Please do as I'm not able to reproduce it. When I hit backspace on empty element, it gets deleted and cursor goes to the element above it.

Could you tell me which version of CKEditor are you using? It is very important.

comment:7 Changed 7 years ago by Ferdinand

I am using version 3.6.2. I think you have to use a native IE to make BACKSPACE key work as described. And then look at the source code.

comment:8 Changed 7 years ago by Jakub Ś

Issue does not occur in latest CKEditor 3.6.4. Please upgrade to latest version.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy