Opened 7 years ago

Closed 7 years ago

#10424 closed Bug (duplicate)

IE: Pasted block content into an inline style creates invalid HTML

Reported by: Teresa Monahan Owned by:
Priority: Normal Milestone:
Component: General Version: 3.6.6
Keywords: IBM Cc: Irina, Satya Minnekanti

Description

To Reproduce:

  • Open any CKEditor 3.x sample in IE and clear the contents.
  • Type some text and use Ctrl+A to select it.
  • Use Ctrl+C and then apply a font-size to the selected content.
  • Place the cursor at the end of the content and press enter.
  • Paste the content using Ctrl+V.
  • Place the cursor anywhere in the pasted content.

Problem: The element paths bar displays body span p. If you inspect this content using developer tools you can see that the pasted paragraph is a child element of the span with the font-size styling.

The editor corrects this when you switch to source mode and back or save the content. However this has a direct impact on users if they have specified a font-size style for p elements in contents.css - see attached screen capture.

This is a customer reported issue. It seems related to ticket #8294. I cannot reproduce it in CKEditor 4.1.

Attachments (1)

10424.GIF (11.0 KB) - added by Teresa Monahan 7 years ago.

Download all attachments as: .zip

Change History (2)

Changed 7 years ago by Teresa Monahan

Attachment: 10424.GIF added

comment:1 Changed 7 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed

@tmonahan this is another TC for same problem. We have 3 tickets for this problem defined - #9207, #8294 and #8736. They all have same cause.

I'm closing this as duplicate of #9207 although it doesn't matter which ticket I select. They all have the same fix.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy