Opened 6 years ago

Closed 6 years ago

#8302 closed Bug (invalid)

Jumping Scroll bar on IE8

Reported by: pgteam Owned by:
Priority: Normal Milestone:
Component: General Version: 3.6
Keywords: Cc:

Description

Jumping scroll bar make wrong scrollbar position when pasting content. Reproduce steps:

  1. input (paste) a large content
  2. copy some content and paste at the bottom of the page or middle of the page,
  3. the scrollbar doesn't show at the correct level to the pasted content position.

Attachments (1)

mytestpage.html (3.3 KB) - added by Jakub Ś 6 years ago.
to use it just copy it into samples folder

Download all attachments as: .zip

Change History (9)

comment:1 Changed 6 years ago by Jakub Ś

Keywords: scrollbar removed
Status: newpending

I have copied some text from .txt and .doc file, than pasted it into CKEditor using CRTL+V or paste button, than copied few lines of text and again pasted using CRTL+V or paste button. In my opinion toolbar was always at right position.

I'll be needing more information here. Like:

  1. Is the issue reproducible in standalone CKEditor.
  2. Are we talking about JS CKEditor or integration like CKEditor for Java/PHP/ASP.NET ... ?
  3. Is it reproducible only in version 3.6 or also in latest stable 3.6.1
  4. Could you provide a file with a content that is causing this bug.
  5. Also If I have missed anything in the steps mentioned above please send more detailed steps to reproduce.

comment:2 Changed 6 years ago by pgteam

Thanks for your reply.

  1. it can reproduce in standalone ckeditor
  2. i am taking about js ckeditor
  3. version 3.6 and 3.6.1 got same problem
  4. it always occur after setHtml and then copy and paste content
  1. steps for reproduce:
    1. setHTML some content which is > one page
    2. copy and paste some content at the end, middle of the passage
    3. after several paste, the scroll bar "jump" to the wrong level which is very annoying . .

comment:3 Changed 6 years ago by Jakub Ś

Still no luck in reproducing the issue.

Please see the attached file - it shows the test case I have prepared.

In this TC I have used setHtml method, than copied some of the ckeditor's earlier pasted content, than pasted it many times in the middle and later at the end but no jumping occurred.

Could I ask you to prepare (maybe correct this one) similar test case file in which reproducing the issue is possible?

Changed 6 years ago by Jakub Ś

Attachment: mytestpage.html added

to use it just copy it into samples folder

comment:4 Changed 6 years ago by Jakub Ś

@pgteam you think you will be able to create/correct mine sample file allowing to reproduce the bug?

comment:5 Changed 6 years ago by Jakub Ś

@pgteam your description of a problem is very unclear. Could I ask you to simplify your description as much as possible so that we could easily sit down and look at steps you have provided and reproduce it.

I'm very determined to reproduce the issue. What is more this issue is linked to forum post http://cksource.com/forums/viewtopic.php?f=11&t=20780.

Both of those descriptions seem like a bug but are very unclear thus disallowing me to reproduce the problem and finding a solution for it. A reduced test case file(s) and clear steps how to reproduce will be much appreciated here.

comment:6 Changed 6 years ago by Jakub Ś

@pgteam could I ask you again to provide clear and detailed description of the problem (just like you did in #8335)?

Also I'm not sure if the issue is the same as the one described here - http://cksource.com/forums/viewtopic.php?f=11&t=20780. If these issues are different could I ask you to add detailed description of the problem in this post or report new issue based on this post?

comment:7 Changed 6 years ago by pgteam

I am so sorry, i've discovered that the code i modified cause this problem. Thanks for your time.

comment:8 Changed 6 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy