Opened 6 years ago

Closed 6 years ago

#8336 closed Bug (invalid)

Parser error? strong / span(style="font-size:xxx") problem?

Reported by: Péter Szabó Owned by:
Priority: Normal Milestone:
Component: Core : Parser Version:
Keywords: Cc:

Description

Hi!

The problem is the following:

When I use the editor and typing in sg, then I select a part of the text or the whole of it and then clicking on the "bold" command it's makes the text bold. But then immediatelly I just simply click on a font-size (ex. 28) the text REMAINS in it's original size (althought I can see the span with size 28 around).

When I play it on the opposite way (first click on the size 28 then click on bold) it's working fine.

The source of the generated output differs only in the order of the "span" and "strong" tags.

The same situation appears when I try to give a html fragment to the editor. The result is the following: If the "strong" is outside and the "span" is inside it's fine. If it's in opposite way it's just wrong.

ex: GOOD:

<p>
	abcd <strong><span style="font-size: 28px">efgh</span></strong> ijkl</p>

WRONG:

<p>
	abcd <span style="font-size: 28px"><strong>efgh</strong></span> ijkl</p>

Change History (2)

comment:1 Changed 6 years ago by Jakub Ś

Keywords: strong / span(style="font-size:xxx") removed
Status: newpending
Version: 3.6.1

I have tested every browser and could not reproduce the issue.

Could you tell me:

  1. What operating system and browser are you using?
  2. What doctype are you using?
  3. Are there any custom settings that you have set for CKEditor and may have influence on this behavior?
  4. Are you using standalone JS CKEditor or integration (like .NET, Java or PHP) CKEditor

comment:2 Changed 6 years ago by Péter Szabó

Resolution: invalid
Status: pendingclosed

Hi! My apologies but there were some invalid stuff in the JS I modified. Sorry for taking your time! I'm closing this ticket.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy