Opened 12 years ago

Closed 11 years ago

#834 closed New Feature (fixed)

use icons instead of text in toolbar

Reported by: tokul@… Owned by:
Priority: Normal Milestone: CKEditor 3.0
Component: General Version:
Keywords: SF Confirmed Cc:

Description

Maybe it is possible to replace Style, Format, Font, Size and Source texts that are written next to dropdown boxes with icons. Text takes too much space on toolbar.


Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=1253476&group_id=75348&atid=543656

Change History (6)

comment:1 Changed 12 years ago by Martin Kou

Reporter: changed from Martin Kou to tokul@…

see editor/_source/classes/fcktoolbarfontscombo.js

FCKToolbarFontsCombo.prototype.GetLabel = function()
{
        return FCKLang.Font ;
}

I suspect, that it can be replaced with

FCKToolbarFontsCombo.prototype.GetLabel = function()
{
        return '<img src="' + FCKConfig.SkinPath +
'toolbar/fontname.gif">';
}

FCKLang.Font can be used for image label. Main issue - lack of icons.


Moved from SF. Original poster: tokul

I think the reason it's text at the moment is so that there doesn't have to be a different image for every language. Perhaps it could be shrunk via css.


Moved from SF. Original poster: Anonymous

comment:2 Changed 12 years ago by Wojciech Olchawa

Keywords: Pending added

What kind of icons would you have in mind? In my opinion if there where images instead of text it's possible that the toolbar wouldn't be so intuitive as it suppose to.

comment:3 Changed 12 years ago by Tomas

Any icon that does not take more than 16x16px. Currently every dropdown box is wasting space that can be used by 2-3 other icons.

Actually I would set Style, Format, Font, Size texts to empty strings. Dropdown boxes are intuitive enough. They would not be intuitive only, if admin rearranges dropdown boxes in non-standard order. Put those texts in tooltips, if it is possible and you want to keep them.

comment:4 Changed 12 years ago by Wojciech Olchawa

Keywords: Discussion added; Pending removed

It's a request we should open a discussion for. Let's see what other think about this idea.

comment:5 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Confirmed added; Discussion removed
Milestone: CKEditor 3.0

For V3, we'll have the dropdown box only, with no labels or icons.

comment:6 Changed 11 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: newclosed

Actually, with V3 we are able to set, by CSS, whether to have or not the labels. The icons, could even be used, by replacing the textual labels with images by CSS. In other words, anything is automated, but now we have full control of it with the proper CSS being applied.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy