Opened 12 years ago

Closed 12 years ago

#835 closed New Feature (duplicate)

use connectors FileUpload command for quick-upload function

Reported by: bemaqua@… Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: SF Cc: Alfonso Martínez de Lizarrondo

Description

use connectors FileUpload command for quick-upload function instead of seperatly one. It does nearly the same and i don't like to do thinks twice ;-)

I use my connector for the quick-upload too (because i want one place to change it, etc.). What i've changed is the Connectors FileUpload- Response where i must give back the uploaded file-url when using Quick-Upload in OnUloadComplete-Callback function. Also we must be aware of the location of that function too ...

<script type="text/javascript">
if (window.parent.frames
['frmUpload'].OnUploadCompleted) {
window.parent.frames['frmUpload'].OnUploadCompleted
(0);
}
else {
window.parent.OnUploadCompleted
(0,'<uploadedfileurl>');
}
</script>

In my Custom-fck-Config File i use this to link the quick- upload function to my connector:

FCKConfig.ImageUploadURL
= '/service/BASIS.FCKEditor.FileBrowser.Connector.cls?
Command=FileUpload&Type=File';

By the way ... my script-language/Connector is for InterSystems Cache-Database with its Cache-Server- Pages Web-Gateway/API.

What i also like is to see a complete and better documentation of the FileBrowser/Service-Side- Integerations ;-)

Thanks and Regards ... Bernd!

Change History (1)

comment:1 Changed 12 years ago by Martin Kou

Cc: Alfonso Martínez de Lizarrondo added
Reporter: changed from Martin Kou to bemaqua@…
Resolution: duplicate
Status: newclosed

As indicated by alfonsoml, this ticket is a duplicate of http://dev.fckeditor.net/454

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy