Opened 6 years ago

Closed 2 weeks ago

#8354 closed Bug (fixed)

Save enabled only in design mode

Reported by: Alfonso Martínez de Lizarrondo Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description (last modified by Frederico Caldeira Knabben)

The save button is restricted by default to design mode only due to this line:

command.modes = { wysiwyg : !!( editor.element.$.form ) };

That setting disables saving in source mode.

Change History (2)

comment:1 Changed 6 years ago by Frederico Caldeira Knabben

Description: modified (diff)
Status: newconfirmed

My fault here... we have this thing since [3285], two years ago.

The modes property is definitely the wrong thing to be used to make this check.

comment:2 Changed 2 weeks ago by Marek Lewandowski

Resolution: fixed
Status: confirmedclosed

Fixed in GitHub#817.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy