Opened 6 years ago

Closed 4 years ago

#8353 closed Bug (wontfix)

IE7: Crash when changing list type

Reported by: Frederico Caldeira Knabben Owned by:
Priority: Normal Milestone:
Component: Core : Lists Version: 3.6.1
Keywords: IE7 Cc:

Description

The following test is crashing IE7:
http://ckeditor.t/tt/7290/1.html

These are the reproduction steps:

  1. Load this HTML:
<ul>
	<li>
		a</li>
	<li>
		b</li>
	<li>
		c</li>
</ul>
  1. Put the caret after "b".
  1. Hit the "Numbered List" button.

The browser will totally crash.

This doesn't happen if doing the same after "a" or "c". It just happens with items in the middle of the list.

Confirmed with CKEditor 3.6.1 at least.

Change History (2)

comment:1 Changed 6 years ago by Frederico Caldeira Knabben

Status: newconfirmed

The failing test has been moved out of master to t/8353:
http://ckeditor.t/tt/7290/1.html

comment:2 Changed 4 years ago by Piotrek Koszuliński

Resolution: wontfix
Status: confirmedclosed

I couldn't reproduce this any more, so I guess it expired.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy