Opened 8 years ago

Closed 8 years ago

#8357 closed Bug (fixed)

IE: Cursor goes to start of editor body when we edit a link using the context menu option

Reported by: Teresa Monahan Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.6.2
Component: General Version: 3.6.2
Keywords: IBM IE NoTest Cc: Damian, Satya Minnekanti

Description (last modified by Wiktor Walc)

To Reproduce:

  1. Using a nightly build, insert some text into the editor body.
  2. Without selecting any text, open the link dialog and insert a URL. Click OK.
  3. Place the cursor inside the link text and right-click to bring up the context menu. Select 'Edit Link' to bring up the link dialog.
  4. Close the link dialog by clicking OK. (Note: there is no need to make any changes to the link values.)

Problem: The cursor is now positioned at the start of the editor body, instead of within the link text.

This only occurs when a link is inserted without any selection in the editor body.

It is only happening since rev [7237] which seemed to add a timeout for an issue in Opera (ticket #8301). Is it possible to limit this fix to Opera alone using CKEDITOR.env.opera instead of applying it to all browsers?

Attachments (1)

8357.patch (691 bytes) - added by Garry Yao 8 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 8 years ago by Jakub Ś

Status: newconfirmed

Reproducible from rev [7237]

Looks like it is very similar to #8345 but that one has occurred first in CKE 3.5.3.

Last edited 8 years ago by Wiktor Walc (previous) (diff)

comment:2 Changed 8 years ago by Wiktor Walc

Description: modified (diff)

comment:4 Changed 8 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.6.2

comment:5 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: IE added

Changed 8 years ago by Garry Yao

Attachment: 8357.patch added

comment:6 Changed 8 years ago by Garry Yao

Owner: set to Garry Yao
Status: confirmedreview

comment:7 Changed 8 years ago by Garry Yao

Similar bug could be found on Opera at #8361.

comment:8 Changed 8 years ago by Frederico Caldeira Knabben

Status: reviewreview_passed

comment:9 Changed 8 years ago by Garry Yao

Keywords: NoTest added
Resolution: fixed
Status: review_passedclosed

Fixed with [7270].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy