Opened 8 years ago

Closed 8 years ago

#8373 closed Bug (invalid)

IE9 adds " entities around URL in style background-image: url(...)

Reported by: Jakub Ś Owned by:
Priority: Normal Milestone:
Component: General Version: 3.1.1
Keywords: IE9 Cc:

Description (last modified by Jakub Ś)

The issue is that in IE9 extra and unnecessary &quote; are added around url.

In user's case such code:

style="background-image: url("
http://www.sauvons-les-animaux.com/images/l/log/logo-22-ligne-blancheff.png");" 

was saved in DB what later was transformed to

style="background-image: url("
http://www.sauvons-les-animaux.com/images/l/log/logo-22-ligne-blancheff.png");"

what later was changed by CKEditor to

<table border="0" cellpadding="0" cellspacing="0" height="145" images=""
l="" log="" style="background-image: none;" width="170"
http://www.sauvons-les-animaux.com="">

Despite of what is changing &quot to ", this wouldn't happen if extra &quot; weren’t added

Change History (5)

comment:1 Changed 8 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 8 years ago by Frederico Caldeira Knabben

Status: confirmedpending

Can you please make the problem simpler and more specific. What's the issue with CKEditor?

comment:3 Changed 8 years ago by Frederico Caldeira Knabben

Similar to #5282.

comment:4 Changed 8 years ago by Jakub Ś

Description: modified (diff)

The issue is that in IE9 extra and unnecessary &quote; are added around url.

In user's case such code:

style="background-image: url(&quot;
http://www.sauvons-les-animaux.com/images/l/log/logo-22-ligne-blancheff.png&quot;);" 

was saved in DB what later was transformed to

style="background-image: url("
http://www.sauvons-les-animaux.com/images/l/log/logo-22-ligne-blancheff.png");"

what later was changed by CKEditor to

<table border="0" cellpadding="0" cellspacing="0" height="145" images=""
l="" log="" style="background-image: none;" width="170"
http://www.sauvons-les-animaux.com="">

Despite of what is changing &quot to ", this wouldn't happen if extra &quot; waren't added

comment:5 in reply to:  4 Changed 8 years ago by Frederico Caldeira Knabben

Resolution: invalid
Status: pendingclosed

Replying to j.swiderski:

Despite of what is changing &quot to ", this wouldn't happen if extra &quot; waren't added

That's the key point here. CKEditor is not, in any way, producing bad HTML. It's normal to have the original HTML changed, in the same way the editor makes lots of other changes to it.

The target application is instead breaking the HTML, in the same way it would break a tag like the following:

<img title="Text with &quot;quotation&quot; marks" src="image.png" />

Doing any kind of change to CKEditor is the wrong way for it. Other than the fact that there is nothing in the editor to get fixed, the application would still stay broken. So, for the health of the application itself, the thing to get fixes is the application.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy