Opened 8 years ago

Closed 8 years ago

#8372 closed Bug (fixed)

Pasting Text and bulleting it causes all lines to be wrapped in single bullet instead of each line being bulleted

Reported by: Michael Camden Owned by:
Priority: Normal Milestone:
Component: Core : Lists Version: 3.0
Keywords: Chrome Cc: mcamden@…

Description

Pasting three paragraphs of text, and applying a bullet to the lines seems to cause CKEDITOR to create a single bullet which wraps the content, and then multiple empty bullets for the other lines.

Steps to reproduce:

  1. Access ckeditor.com/demo
  2. Clear out the content.
  3. Copy and paste the attached document using, CTRL+C/CTRL+V
  4. Select all the text and apply a bulleted list

Attachments (2)

Investigation.docx (10.5 KB) - added by Michael Camden 8 years ago.
Content for the bug
13423.png (62.2 KB) - added by Michael Camden 8 years ago.
Screenshot of error

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by Michael Camden

Attachment: Investigation.docx added

Content for the bug

Changed 8 years ago by Michael Camden

Attachment: 13423.png added

Screenshot of error

comment:1 Changed 8 years ago by Jakub Ś

Keywords: chrome bullet windows 7 removed
Status: newconfirmed
Version: 3.63.0

To reproduce:

  1. Open docx, select its contents and press CRTL+C
  2. Open replace by code sample
  3. Press CRTL+A
  4. Press BACKSPACE ONCE
  5. Paste the docx contents using CRTL+V
  6. Press CRTL+A and click bulleted list

Result: All paragraphs are inside one li

In step 4 if you press backspace couple of times the problem is gone.

comment:2 Changed 8 years ago by Jakub Ś

Keywords: Chrome added

comment:3 Changed 8 years ago by Michael Camden

This issue appears to have been resolved in 3.6.2.

comment:4 Changed 8 years ago by Jakub Ś

Resolution: fixed
Status: confirmedclosed

It seems to be working across all CKEditor versions. I guess that new Chrome 15 has fixed the issue.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy