Opened 8 years ago

Closed 6 years ago

#8421 closed Bug (fixed)

Language files not loading properly for the a11yhelp plugin

Reported by: Teresa Monahan Owned by:
Priority: Normal Milestone:
Component: General Version: 3.5.3
Keywords: IBM Cc: Damian, Satya Minnekanti

Description

To Reproduce:

  1. Open ui_languages.html in the _samples directory.
  2. Click into the editor and press ALT+0 to load the a11y help instructions. The help dialog is displayed and the contents are in English.
  3. Now change the language to Hebrew.
  4. Click into the editor and press ALT+0 to load the a11y help instructions again.

Problem: The help dialog is displayed and the contents are still in English. The contents should now be displayed in Hebrew.

We believe the issue is that the previous language is not getting overwritten when a new language is selected. The following code change in a11yhelp\plugin.js seems to fix this problem:

Current Code:

CKEDITOR.tools.extend( editor.lang, plugin.langEntries[ langCode ] );

Proposed Fix:

CKEDITOR.tools.extend( editor.lang, plugin.langEntries[ langCode ],true );

This issue arose during our translation process for 3.6.2. It is an important issue for us to address in 3.6.x since all our language resources for this plugin are now located in the a11yhelp\lang directory.

Change History (3)

comment:1 Changed 8 years ago by Jakub Ś

Status: newconfirmed
Version: 3.6.23.5.3

Reproducible from CKEditor 3.5.3.

NOTE:
Before CKE 3.5.3 - pressing ALT+0, changing language and pressing ALT+) again caused JS error:
Message: array.indexOf is not a function
Line: 522
URI: 3.5.2/ckeditor/_source/core/tools.js

comment:2 Changed 8 years ago by Jakub Ś

#8900 was marked as duplicate.

comment:3 Changed 6 years ago by Olek Nowodziński

Resolution: fixed
Status: confirmedclosed

I'm not able to reproduce the issue (4.3.2).

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy