Opened 10 years ago

Closed 10 years ago

#8422 closed Bug (worksforme)

Anchor name is uri escaped

Reported by: usami Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

The anchor name is uri escaped when making it with non-alphabetical characters.

  1. create document with anchor in non-alphabetical characters.
  2. save the document.
  3. edit the document and open anchor properties.
  4. anchor name is uri escaped.

Attachments (1)

escaped.png (6.4 KB) - added by usami 10 years ago.

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by usami

Attachment: escaped.png added

comment:1 Changed 10 years ago by Jakub Ś

Status: newpending
  1. save the document.
  2. edit the document and open anchor properties.

Could you check and give me feedback what do you receive (net tab in Firebug) when you load back the document. It looks more like an encoding problem on your side.

comment:2 Changed 10 years ago by usami

The response of the request

<!DOCTYPE HTML PUBLIC "-//W3C//DTD XHTML 1.1//EN">
<html xmlns="http://www.w3.org/1999/xhtml">
<body>
<p>
<a name="%E3%81%82%E3%82%93%E3%81%8B%E3%83%BC"></a>
</p>

</body>
</html>

is this what you asked for?

Also I checked the HTML of the anchor by Firebug html tab.

<a name="あんかー" data-cke-saved-name="%E3%81%82%E3%82%93%E3%81%8B%E3%83%BC"></a>

comment:3 Changed 10 years ago by Jakub Ś

Resolution: worksforme
Status: pendingclosed

If this is what you get in your response than this is what comes from your server.

&lt;a name=&quot;%E3%81%82%E3%82%93%E3%81%8B%E3%83%BC&quot;&gt;&lt;/a&gt;

This is not CKEditor fault. Please try to look for the cause on your side.

You could start with seeing what gets written into DB or what how does your request look like. Perhaps you are not decoding your data?

Note: See TracTickets for help on using tickets.
© 2003 – 2021 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy