Opened 8 years ago

Closed 8 years ago

#8436 closed Bug (duplicate)

Redundant empty paragraph added after div elements

Reported by: Ildefonse Owned by:
Priority: Normal Milestone:
Component: UI : Source View Version:
Keywords: Cc:

Description

A redundant empty paragraph is added after div elements for no reason after switching out and back in to source view.

Tested in 3.6.2 and confirmed on the latest nightly demo: http://nightly.ckeditor.com/7293/_samples/replacebyclass.html

To reproduce, go to the editor, go to source mode, enter the following HTML:

<p>
	&nbsp;</p>
<p>
	some text</p>
<div class="reply">
	<p>
		test</p>
</div>

Perfectly valid HTML. Now exit source mode, and click on the first paragraph (with the space) and type something. Re-enter source mode and observe how the code changed to:

<p>
	sdf</p>
<p>
	some text</p>
<div class="reply">
	<p>
		test</p>
</div>
<p>
	&nbsp;</p>

An empty paragraph has been added after the div, for no reason at all that I can think of.

This is experienced on Mac OS X, running in the latest version of Chrome. Also confirmed in Firefox on Mac, and in Chrome on Ubuntu.

This bug does NOT seem to be present in CKeditor version: 3.4.2

Possibly related to bug #3684, which has been marked as fixed though: http://dev.ckeditor.com/ticket/3684

Change History (1)

comment:1 Changed 8 years ago by Jakub Ś

Keywords: empty paragraph div removed
Resolution: duplicate
Status: newclosed
Version: 3.6.3 (SVN - trunk)

This issue is a duplicate of #8419.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy