Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#8437 closed Bug (duplicate)

background of text run pasted from Word

Reported by: Zee Owned by:
Priority: Normal Milestone:
Component: Plugin : Paste from Word Version: 3.6.2
Keywords: Cc:

Description

Situation: Pasting text from Word into CKEditor

Problem: Background property of the text is set wrong

Here is document source:

<p>
    <strong>
        <span style="background:lime;">
            <span style="color:white;">
                <span style="font-size:36.0pt;">WORD</span>
            </span>
        </span>
    </strong>
    <strong>
        <span style="font-size:36.0pt;">
            <span style="background:teal;">
                <span style="color:white;">ABC</span>
            </span>
        </span>
    </strong>
</p>

CKEditor for some reason inverted hiearchy of <span> elements of the first word. In "word paste dialog" text is displayed correctly.

Attachments (4)

TextInWord.png (47.8 KB) - added by Zee 6 years ago.
Text in Microsoft Word
TextInDialog.png (14.9 KB) - added by Zee 6 years ago.
Text in Paste from Word dialog
TextInEditor.png (6.7 KB) - added by Zee 6 years ago.
Text in editor
WORD_ABC.doc (23.5 KB) - added by Jakub Ś 6 years ago.

Download all attachments as: .zip

Change History (8)

Changed 6 years ago by Zee

Attachment: TextInWord.png added

Text in Microsoft Word

Changed 6 years ago by Zee

Attachment: TextInDialog.png added

Text in Paste from Word dialog

Changed 6 years ago by Zee

Attachment: TextInEditor.png added

Text in editor

comment:1 Changed 6 years ago by Frederico Caldeira Knabben

Component: GeneralCore : Pasting
Keywords: Background Paste removed
Status: newconfirmed

comment:2 Changed 6 years ago by Jakub Ś

@Zee you think it would be possible to attach doc file you have used for this ticked?

Changed 6 years ago by Jakub Ś

Attachment: WORD_ABC.doc added

comment:3 Changed 6 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed

I attaching sample file that shows result very similar to the one that user has reported.

Anyway this is a duplicate of #8181.

If CKEditor could wisely switch spans from

<span style="background:lime;">
       <span style="color:white;">
           <span style="font-size:36.0pt;">WORD</span>
       </span>
</span>

to (size around background color)

<span style="font-size:36.0pt;">
    <span style="background:teal;">
         <span style="color:white;">ABC</span>
</span>

Problem would be solved.

comment:4 Changed 4 years ago by Frederico Caldeira Knabben

Component: Core : PastingPlugin : Paste from Word
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy