Opened 8 years ago

Closed 8 years ago

#8464 closed Bug (duplicate)

Choose background color of table does not close dialog in IE

Reported by: Mark Ramos Owned by:
Priority: Normal Milestone:
Component: Core : Tables Version: 3.6.2
Keywords: Cc: mark.ramos@…, john.naldoza@…

Description

From : http://cksource.com/forums/viewtopic.php?p=60688#p60688

On IE8 and IE9 with CKEditor 3.6.2, we find that we can select multiple cells by selecting the first cell, then shift-click in the last cell (say in a row -- also dragging across rows seems to select them too). If we right click to set the cell properties, it sometimes only ends up selecting the last cell. But when we are able to select the entire row and choose to set the background color, we get the following JS error:

Line: 51 Error: Object doesn't support property or method 'data'

SCRIPT438: Object doesn't support property or method 'data' ckeditor.js, line 51 character 1842

and it highlights this: if(A.data('cke-display-name'))

At that point, the cell properties dialog will not close on OK button, but will if you click CANCEL button (then OK on a dialog about "some options have changed". The cells actually seem to show the new background color like it was successful.

This can be reproduced easily using your stock demo.

Change History (1)

comment:1 Changed 8 years ago by Jakub Ś

Keywords: background color table cell properties dialog internet explorer IE removed
Resolution: duplicate
Status: newclosed

This is a duplicate of #8400

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy