Ticket #8475 (closed Bug: fixed)

Opened 2 years ago

Last modified 2 years ago

Problems with deleting font tags in table.

Reported by: j.swiderski Owned by:
Priority: Normal Milestone: CKEditor 3.6.3
Component: General Version: 3.6.2
Keywords: Cc:

Description (last modified by j.swiderski) (diff)

  1. Paste the below code:
    <table border="0" cellpadding="0" cellspacing="0" style="width: 650px;">
    <tbody>
    <tr>
    <td style="text-align: left;">
    <font size="4"><font face="Leckerli One"><font size="5">V</font>ous
    trouverez dans le menu de gauche diff&eacute;rentes cat&eacute;gories de
    photos class&eacute;es par th&egrave;mes.<br />
    Ces photographies repr&eacute;sentent des instants furtifs auxquels
    j'ai eu la chance d'assister, j'esp&egrave;re que vous prendrez
    autant de plaisir &agrave; les regarder que j'en ai eu &agrave; les
    prendre.J'en ajoute r&eacute;guli&egrave;rement, et &agrave; terme, il y
    en aura des centaines, n'h&eacute;sitez donc pas &agrave; venir de temps
    en temps pour en voir de nouvelles.<br />
    Lorsque ma boutique sera en ligne, il vous sera possible de vous
    procurer des produits d&eacute;riv&eacute;s de mes photos, comme des cartes
    postales, des posters, des calendriers...</font></font></td>
    </tr>
    </tbody>
    </table>
    <p>
    &nbsp;</p>
    
  1. Select ^trouverez dans le menu de gauche^
  2. Press delete or backspace

Results:
Webkit - nothing happens. You have to repeat step 2 & 3 to delete text

Opera - 't' or space before 't' is removed. If you repeat steps 2 & 3 text will be deleted.

Firefox - first letter of selection or space/letter that is before first letter of selection will be removed. If you select V^ous trouverez dans le menu de gauche^ text will be deleted normally. This is probably because 'V' is in different font tag

IE - works fine

Issue has been reproducible from CKEditor 3.6.2 rev [7243]

Change History

comment:1 Changed 2 years ago by j.swiderski

  • Status changed from new to confirmed
  • Description modified (diff)

comment:2 Changed 2 years ago by j.swiderski

The same thing will happen if instead of deprecated font tags you will use spans with styles:

<table border="0" cellpadding="0" cellspacing="0" style="width: 650px;">
	<tbody>
		<tr>
			<td style="text-align: left;">
				<span style="font-family:comic sans ms,cursive;"><span style="font-size: 14px;"><span style="font-size: 26px;">V</span>ous rouverez dans le menu de gauche diff&eacute;rentes cat&eacute;gories de photos class&eacute;es par th&egrave;mes.<br />
				Ces photographies repr&eacute;sentent des instants furtifs auxquels j&#39;ai eu la chance d&#39;assister, j&#39;esp&egrave;re que vous prendrez autant de plaisir &agrave; les regarder que j&#39;en ai eu &agrave; les prendre.J&#39;en ajoute r&eacute;guli&egrave;rement, et &agrave; terme, il y en aura des centaines, n&#39;h&eacute;sitez donc pas &agrave; venir de temps en temps pour en voir de nouvelles.<br />
				Lorsque ma boutique sera en ligne, il vous sera possible de vous procurer des produits d&eacute;riv&eacute;s de mes photos, comme des cartes postales, des posters, des calendriers..</span>.</span></td>
		</tr>
	</tbody>
</table>
<p>
	&nbsp;</p>

comment:3 Changed 2 years ago by j.swiderski

Possible duplicate (different TC, same revision) was reported in #8493.

Last edited 2 years ago by j.swiderski (previous) (diff)

comment:4 Changed 2 years ago by j.swiderski

Other tickets caused by rev [7243]: #8455, #8632, #8493

comment:5 Changed 2 years ago by garry.yao

  • Status changed from confirmed to closed
  • Resolution set to fixed

Fixed by #8632.

comment:6 Changed 2 years ago by wwalc

  • Milestone set to CKEditor 3.6.3
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy