Opened 7 years ago

Closed 6 years ago

#8492 closed Bug (fixed)

Can't move cursor behind non-editable element (or placeholder) in CKEditor

Reported by: Jakub Ś Owned by:
Priority: Normal Milestone:
Component: General Version: 3.3
Keywords: Cc:

Description (last modified by Jakub Ś)

To reproduce:

  1. Open replacebycode sample and clear editor contents.
  2. Paste in the following code:
    <p><span contenteditable="false" unselectable="on">[[UMR]]</span></p>
    
  3. Put the cursor behind [[UMR]]^ and try to move with arrows

Results:

FF - you can't. You can however workaround this with up/down arrows or Home/End buttons
The same thing happens for placeholder.

IE8 - You can't move cursor behind [[UMR]]^. The issue has been reproducible from CKEditor 3.3.
The same thing happens for placeholder.
IE8 has also problem with form elements #5349 and images #8446.

Opera - the line with [[UMR]] is not accessible. This issue has also been reproducible from CKEditor 3.3 but you can also reproduce it in plain browser without any CKEditor logic (Perhaps earlier releases had something that helped to omit the problem).
The same thing happens for placeholder.

Chrome - Works but you can't see the cursor after you click behind [[UMR]]^ (From CKEditor 3.0).

Currently the only way to workaround the issue is to use code like:

<p>
	<span contenteditable="false" unselectable="on">[[UMR]]</span><span>&nbsp;</span></p>

Change History (5)

comment:1 Changed 7 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 6 years ago by Jakub Ś

Description: modified (diff)
Summary: Can't move cursor behind non-editable element in CKEditorCan't move cursor behind non-editable element (or placeholder) in CKEditor

comment:3 Changed 6 years ago by Jakub Ś

#8990 was marked as duplicate.

comment:4 Changed 6 years ago by Jakub Ś

Description: modified (diff)

comment:5 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

It seems that this was fixed by the Widget System.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy