Opened 7 years ago

Closed 7 years ago

#8535 closed Bug (duplicate)

Bug: - hide() is not working with IE 7 for CKEditor 3.6.2.0

Reported by: Siju Owned by:
Priority: Normal Milestone:
Component: General Version: 3.6.2
Keywords: hide() not working in IE7 Cc: sithomas@…, blkishor@…, PRodibaugh@…

Description

Hi,

We are using 3.6.2.0 version of CKEditor in our project and noticed an issue recently with CKEditor's compatibility with IE7. We have the functionality in the editor to hide the images through javascript which is not working on IE 7 browser and working in IE 8, Firefox etc.

We have tried all the alternatives and couldn’t find a proper solution for it. Since our most clients are using IE 7 we have to keep a fix for this issue. It would really appreciated if we could get any guidance / help towards this.

Please find the code snippet of Js (bottom) which we are using. It is being noticed that the hide() method is working on IE7. As indicated in CKEditor’s documentation it is setting the display:none for the element. From the debug we could fin d the style.display become “none” but it is not hiding the image. Even we have tried to set the isVisible = false. But no luck yet for our researches.

It would be nice if you could help us for giving some details which we are expecting: 1) Whether this is a bug with CKEditor ? , If so any fix or work around 2) Whether we did something wrong?

Code Snippet (JS):

var editor = getEditor(); for (var i = 0; i < imgArray.length; i++) {

var obj = editor.document.getById(imgArray[i].id); obj.hide();

}

Thanks In Advance. Siju Thomas.

Change History (2)

comment:1 Changed 7 years ago by Siju

We have also tried obj.setStyle("display","none"); obj.$.style.display = "none"

comment:2 Changed 7 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed

This is a duplicate of #2848.

@sijuthomasp I have attached sample file showing how to workaround the problem. The workaround is not ideal but this is the best you can do without modifying the source code.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy