Opened 8 years ago

Closed 7 years ago

#8569 closed Bug (fixed)

FF: JS error when inserting elements after HTML with comments.

Reported by: Jakub Ś Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone:
Component: General Version: 3.6.1
Keywords: IE Cc:

Description (last modified by Jakub Ś)

Ticket has been reported on our support channel - Topic - "Possible bug: HTML comments cause Javascript error when integrating CKFinder with CKEditor"

  1. Insert on of the following
    <!--A comment-->
    <div><!--A comment--></div>
    <div>Something else</div><!-- A comment -->
    <div><div>Something else</div><!-- A comment --></div>
    
  2. Try to insert Image/Table/Link/Page break using toolbar buttons.
  3. After pressing OK JS error pops out.

The error:
Message: startNode.getChildCount is not a function
Line: 792
URI: ckeditor/_source/core/dom/range.js

Bug is only reproducible in Firefox 4-10 and IE 6-9 (FF 3.6 is fine).

Ticket has been reproducible from CKE 3.6.1 rev [6963]

NOTE:
Before this revision another error was thrown (from CKE 3.3)
Message: startContainer.getChild is not a function
URI: /3.6/_source/core/dom/range.js
Line: 1472

Attachments (1)

8569.patch (764 bytes) - added by Frederico Caldeira Knabben 7 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 8 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 8 years ago by Jakub Ś

Description: modified (diff)

comment:3 Changed 8 years ago by Jakub Ś

Description: modified (diff)
Keywords: IE added

comment:4 Changed 8 years ago by Jakub Ś

Similar problem: #8732

Other related to problems with HTML comments: #8640, #8216, #8129, #6709, #8812

Last edited 7 years ago by Jakub Ś (previous) (diff)

comment:5 Changed 7 years ago by Frederico Caldeira Knabben

Status: confirmedpending

I as not able to reproduce this issue on trunk.

There is one thing that is not clear for me in the tc... where should the selection be before trying to insert?

comment:6 Changed 7 years ago by Jakub Ś

Keywords: Firefox removed
Status: pendingconfirmed

I can still reproduce it on trunk.

  1. Paste in source mode <!--A comment-->
  2. switch to wysiwyg
  3. Click behind comment (In my case when I do click cursor is in the same line as comment but far to the right - below background color button)
  4. insert table

Reproducible only in IE.

Changed 7 years ago by Frederico Caldeira Knabben

Attachment: 8569.patch added

comment:7 Changed 7 years ago by Frederico Caldeira Knabben

Owner: set to Frederico Caldeira Knabben
Status: confirmedreview

#8812 must be closed first, because both fixes are required to have this ticket fixed.

comment:8 Changed 7 years ago by Frederico Caldeira Knabben

Status: reviewassigned

This one is supposed to get fixed by #8812.

Last edited 7 years ago by Frederico Caldeira Knabben (previous) (diff)

comment:9 Changed 7 years ago by Jakub Ś

Resolution: fixed
Status: assignedclosed

Working on a current trunk.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy