Opened 5 years ago

Closed 5 years ago

#8812 closed Bug (fixed)

IE9: HTML comment blocks Enter Key

Reported by: Jakub Ś Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 3.6.3
Component: Core : Selection Version: 3.0
Keywords: IE9 Cc:

Description

  1. open the http://ckeditor.com/demo/ in IE9
  2. press source button to switch to source mode.
  3. remove all default contents.
  4. input this line. test <!-- -->
  5. press source button and switch to WYSIWYG mode.
  6. Click in editor (doesn't matter where) and press Enter key.

Result: Enter key does not work.

Attachments (3)

8812.patch (793 bytes) - added by Frederico Caldeira Knabben 5 years ago.
8812_2.patch (1.3 KB) - added by Frederico Caldeira Knabben 5 years ago.
8812_3.patch (2.3 KB) - added by Frederico Caldeira Knabben 5 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 5 years ago by Jakub Ś

Status: newconfirmed

Changed 5 years ago by Frederico Caldeira Knabben

Attachment: 8812.patch added

comment:2 Changed 5 years ago by Frederico Caldeira Knabben

Owner: set to Frederico Caldeira Knabben
Status: confirmedreview

comment:3 Changed 5 years ago by Garry Yao

Status: reviewreview_failed

Patch fails the following tc:

http://ckeditor.t/tt/8812/1.html

Changed 5 years ago by Frederico Caldeira Knabben

Attachment: 8812_2.patch added

comment:4 Changed 5 years ago by Frederico Caldeira Knabben

Component: GeneralCore : Selection
Status: review_failedreview

The previous patch was working on a sightly different tc than the provided one. Because of this I've updated the test, adding both tcs there.

The new patch fixes instead the root of the problem, which is related to the IE Range to CKEDITOR.dom.range transformation. This is a more global fix, which can help us avoiding unknown issues all around the code.

comment:5 Changed 5 years ago by Frederico Caldeira Knabben

The provide patch fixes #8569 as well.

comment:6 Changed 5 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.6.3

comment:7 Changed 5 years ago by Garry Yao

Status: reviewreview_failed

Patch fails one tc that is added to the ticket test, pls check, basically the patch needs to change also the "else" block in the range mapping hunk.

Changed 5 years ago by Frederico Caldeira Knabben

Attachment: 8812_3.patch added

comment:8 Changed 5 years ago by Frederico Caldeira Knabben

Status: review_failedreview

comment:9 Changed 5 years ago by Garry Yao

Status: reviewreview_passed

comment:10 Changed 5 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: review_passedclosed

Fixed with [7415].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy