Opened 8 years ago

Closed 7 years ago

#8618 closed Bug (fixed)

Paste from MS Word works incorrectly in FF9.0.1

Reported by: Lukasz Kurek Owned by:
Priority: Normal Milestone:
Component: Core : Pasting Version: 3.0
Keywords: Firefox9 Cc:

Description

When I copy table from MS Word and paste it to the Ckeditor, I get text instead of table. This is only in FF9.0.1, for Chrome and IE works fine

Change History (7)

comment:1 Changed 8 years ago by Jakub Ś

Keywords: Firefox9 added
Status: newconfirmed
Version: 3.6.23.0

Looks like some Firefox 9.0.1 incompatibility since it works in all previous versions.

In Firefox 9 this issue can be reproduced from CKEditor 3.0.

comment:2 Changed 8 years ago by Jakub Ś

Component: GeneralCore : Pasting
Summary: Paste from MS Word works incorrectly for tables in FF9.0.1Paste from MS Word works incorrectly in FF9.0.1

It seems that formatting is lost not only for tables but also for texts as mentioned in #8655.

When I paste text from MS Word 2003, which is in bold, different colors and two different sizes, the result is everything in default black and the same text size.

Also links get pasted as text.

Last edited 7 years ago by Jakub Ś (previous) (diff)

comment:3 Changed 8 years ago by Jakub Ś

#8655 was marked as duplicate.

comment:4 Changed 7 years ago by Mikko Kinnunen

Confirmed also on Firefox 10.0b4.

This only happens if your Windows locale is set to use comma "," as decimal separator. Switching the decimal separator to "." and restarting Firefox made the problem go away for me at least.

Relevant bugzilla discussions:
https://bugzilla.mozilla.org/show_bug.cgi?id=714115
https://bugzilla.mozilla.org/show_bug.cgi?id=718592
Seems to be a Firefox problem, to be fixed by Mozilla.

comment:5 Changed 7 years ago by Jakub Ś

In #8665 the problem with formatting in FF9 was also mentioned.

comment:6 Changed 7 years ago by Mikko Kinnunen

This has been fixed in Firefox 10.0

comment:7 Changed 7 years ago by Jakub Ś

Resolution: fixed
Status: confirmedclosed

Confirmed - issue no longer occurs in FF10

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy