Opened 7 years ago

Closed 4 years ago

#8622 closed Bug (wontfix)

Opera: problems with splitting table cells

Reported by: Jakub Ś Owned by:
Priority: Normal Milestone:
Component: General Version: 3.4.2
Keywords: Opera Cc: Hallvord R. M. Steen (Opera Software)

Description (last modified by Jakub Ś)

This issue may be related to #8072.


Scenario 1

  1. Open replacebycode sample but clear editor contents
  2. Under sample text insert a table with First Row as Headers and default values for Rows & Columns.
  3. Enter "a" & "b" as the values for the cells in the first row (header).
  4. Split the last cell (with "b") in the first row vertically.

Reslut: Notice that new cell appears under "a" not under "b" like in other browsers

Source code is the same as in other browsers:

         <thead>
                <tr>
			<th rowspan="2" scope="col">
				a</th>
			<th scope="col">
				b</th>
		</tr>
		<tr>
			<th scope="col">
				&nbsp;</th>
		</tr>
	</thead>

NOTE: You don't have to create header as first row to get the effect. All you have to do is filling table cells with some values


Scenario 2

  1. Open replacebycode sample but this time DON'T clear editor contents
  2. Under sample text insert a table with First Row as Headers and default values for Rows & Columns.
  3. Enter "a" & "b" as the values for the cells in the first row (header).
  4. Split the last cell (with "b") in the first row vertically.

Result: Cursor jumps up to paragraph, cells don't get splitted and JS error is thrown:
Message: TypeError: Cannot convert 'cell' to object
Line 665
URI: /3.6.2/ckeditor/_source/plugins/tabletools/plugin.js:

I have managed to reproduce it from CKEditor 3.4.2 - since this is the version where CKEditor menu has started working again on right-click.

Change History (5)

comment:1 Changed 7 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 6 years ago by Jakub Ś

Description: modified (diff)

comment:3 Changed 6 years ago by Jakub Ś

Description: modified (diff)

comment:4 Changed 4 years ago by Jakub Ś

Both issues can no longer be reproduced in latest CKEditor 4.x and new Opera 18.

comment:5 Changed 4 years ago by Piotrek Koszuliński

Resolution: wontfix
Status: confirmedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy